what is "Another clk on Guido configured as primary"

Unanswered Question

Hi there,

just a short question with this error message.

there is an issue with a 2651XM router, when the first bri(what is on the WIC slot) goes down and try to change the clocking to the next BRI module what is on a NM-HD-2V slot.

The issue happens now, there is many hundreds of error message says "Another clk on Guido configured as primary" and sometimes the router crash, sometimes not.

I like to know what is exactly the Guido (in my understanding this is the SW on the IOS what handle the NM-HD-2V module) and why I can not set the network-clock-select for the bri cards with this router. As per the Command LookupTool it supported since 12.3.11 and I've 12.4 right now. Is this platform can handle network clock selecting with bri's?

thanks in advance!

Gaba

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Loading.
fred.s.mollenkopf Wed, 03/14/2007 - 12:33

Gaba,

Not 100% sure on this because typically I deploy this with T1/E1. I believe for VWIC BRIs that command cannot be used. Below is a blurb from the network-clock-participate command that goes with the select command.

network-clock-participate

To allow the ports on a specified network module or voice/WAN interface card (VWIC) to use the network clock for timing, use the network-clock-participate command in global configuration mode. To restrict the device to use only its own clock signals, use the no form of this command.

The only VWICs that can participate in network clocking are digital T1/E1 packet voice trunk network modules (NM-HDV), and Fast Ethernet network modules (NM-2W, NM-1FE. and NM-2FE).

As far as the network-clock-select, that might reference WIC based BRI only and not VWIC. The default on that platform is.

Command Default

Cisco 2600 series and Cisco 2600XM

The network clock source is the Advanced Integration Module (AIM) phase-locked loop (PLL) with priority 5, which indicates that the network clock is in free running mode.

Sorry it's not a definite answer to your question but it's how I read it.

Please rate any helpful posts

Thanks

Fred

Fred,

First of all very appreciated for your reply on this topic!

Well, the network clock participate is a different things here. It is not a solution unfortunately because there is two different clock source here. One from the WIC-BRI and the other one from the NM-HDV slot BRI's. and if the BRI on the WIC fails can not fall back to the NM-HDV ones.

As the command says right now the clock is in free running mode, (network-clock-participate is disabled on the WIC and SLOT 1 as well)

I'm using VIC BRI's on the NM-HDV and WanIntCard BRI on the motherboard slot. So as per the command I can not participate the NM BRI's with clocking, but how I can set that the NM-BRI provide the first priority clocking on this GW? Do you this is there any way to change it? (with the network-clock-select I can NOT set any option)

Gaba

fred.s.mollenkopf Fri, 03/16/2007 - 12:55

Gaba,

I know the network-clock-participate and select commands act differently on various platforms, but in my experience you cannot use the network-clock-select command without the network-clock-participate on a 37xx,28xx,38xx router. Of course, again, it might be mainly the platforms I worked on and I'm unsure about the 2651xm. Here is the output of a lab 2811 for you.

no network-clock-participate slot 1

R3(config)#network-clock-select 1 t1 1/0/1

*** Controller T1 1/0/1 is configured not to participate in System Clocking.

If I add the participate then I can specify my priority with no error.

R3(config)#network-clock-participate slot 1

R3(config)#network-clock-select 1 t1 1/0/1

Just to see, try doing network-clock-participate on the WIC, then see if you can use the network-clock-select. Again, this is how I read it and I'm not by far a clocking expert, just know enough to get by.

Thanks for the points for my effort and hope this helps.

Fred

Fred,

Thanks for the reply, that is very useful info!

But unfortunately I'm familiar with this info that w/o participate I can not select the clocking. That is normal behavior.

My issue that I can not participate the VIC-BRI's on the NM-HDV slot and I can not set the clocking for any BRI on this 2651XM platform. so basically I can not handle the clock seletcting on this HW.

the only question if there is any way to set the clocking to the BRI's on the NM-HDV slot?

With 28XX there is no issue, I've done it many times (I have been working on the Cisco-TAC ;-) ) but with 26XX I didn't found any way...

Regards,

Gaba

Fred,

With my colleagues we've found a resolution for this issue: "network-clock-priority " under BRI int config mode.

By default all int has high priority but if you set all with low except of one what keeps in high, it'll be the master clock interface :

Router#sh controll bri 1/0

BRI unit 8:

Current port master clock:recovered from BRI1/0

Router#sh controll bri 1/0

BRI unit 9:

Current port master clock:recovered from BRI1/0

and if the master interface goes down, all the other interface will goes to "freerun" mode :

Router#sh controller bri 1/0

BRI unit 9:

Current port master clock:local osc on this network module

and you can play with the settings further...

Hope this helps you too!

Regards,

Gaba

fred.s.mollenkopf Tue, 03/20/2007 - 08:34

Gaba,

Thanks for the reply and hopefully it'll help someone else on the forum at sometime. Definite 5 Points from me.

Thanks

Fred

Actions

This Discussion