7970G not booting up, stuck at Upgrading screen

Unanswered Question
Mar 14th, 2007

After upgrading CCM for DST, etc patches we have 1 7970 model phone that is not coming back up. Servers were upgraded Friday night and on Monday morning, one of the phones was still showing as Not Found in CCM and when we went to the phone it had Upgrading on the display still , all weekend apparently. The phone did not respond and there was no activity on the display so appeared it was locked up or something, since a majority of the phones were back up and working shortly after the updates were finished on new firmware.

We hard booted the phone (removed power/inline power) and it goes to the same upgrading screen right away.

We tried the factory default key sequence also a few times with no effect.

Any way to get this phone back operational? Unfortunately, the phone is out of warranty and not under a contract so I'm not able to get a cisco case open on it to get it replaced until a contract is purchased on it.

Thanks, Erick

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Paolo Bevilacqua Wed, 03/14/2007 - 13:00

The phone may be looking for files that do no exist on the TFTP server. The problem is that with CCM, the TFTP request is not easy to diagnose, or at least I don't know how to do that.

So I use tftp32 on a PC,


copy all the needed files, and use the "log" window to see what the phone is requesting, if necessary rename files to give them the needed files.

sohaildxbfze Wed, 03/14/2007 - 13:18

simply delete 7970 profile 4rom CCM, then

then be sure about voice vlan config .


Erick Bergquist Wed, 03/14/2007 - 14:29

That did not work, but seem to have something different on LCD now.

After putting switchport in voice vlan directly and powering off phone again, with phone off hook for backup load to be used.

On LCD screen it shows logo then up in corner has checkbox, with X and then a circle eventually then it resets and cycles , and repeats and we watched it cycle 4-5 times.

The phone is not getting far enough to get IP address ; also tried a factory default via keyboard sequence again , no change, it resets with same thing happening on LCD display.

switch#show cdp nei fa3/37 de


Device ID: SEP00115C0E566D

Entry address(es):

Platform: Cisco IP Phone 7970, Capabilities: Host Phone

Interface: FastEthernet3/37, Port ID (outgoing port): Port 1

Holdtime : 171 sec

Version :


advertisement version: 2

Duplex: full

Power drawn: 6.300 Watts

interface FastEthernet3/37

switchport access vlan 20

switchport mode access

switchport voice vlan 20

qos trust device cisco-phone

qos trust cos

spanning-tree portfast

Paolo Bevilacqua Wed, 03/14/2007 - 14:51

Hello, my suggestions stands, the inners of intractions of CCM/switch/phone upgrades are just too much of an headache to debug, that is why I suggest you to connect to a PC with tftp32 and do the upgrade manually. A little time consuming, but results are guaranteed.


This Discussion