Reasons why a Catalyst 3560 would lose it's config

Unanswered Question
Mar 14th, 2007

Assuming the config was saved numerous times... is there *any* possible reason why a switch would lose it's configuration other than performing a password recovery?

I tried to get into one of our Cat 3560's and none of my passwords worked. As a last resort, I tried the password combo when the device was first deployed, it worked.

When I got in, I noticed it was at the "Switch>" prompt. Did a 'sh run' and a majority, not all, of the parameters I configured were gone. I would have dismissed this as a fluke power cycle anomoly wherein it reverted back to it's original config other than we've noticed this same issue with routers at this particular site.

Before we go accusing someone of breaking into our equipment I want to make sure it couldn't be anything else.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
sundar.palaniappan Wed, 03/14/2007 - 12:40

It appears the config register wasn't reverted back to the normal setting of 0x2102 after you did the password recovery. The config register may still be set to 0x2142 and this would cause the switch to ignore the startup config every time it's rebooted.

Access the switch CLI, set the 'config-register 0x2102' from the config mode, save the config and reload and that should clear the problem.

HTH

Sundar

CSCO10203269 Wed, 03/14/2007 - 12:52

Sundar,

I did not perform a password recovery, the switch was brand new out of the box before it was deployed. My concern is someone performed a password recovery after the device was already deployed. We've seen the same things with brand new routers at this particular site. After several months of working, the config would revert back to the original config.

glen.grant Wed, 03/14/2007 - 14:16

I have never heard or seen that if the config register is correct . I have seen so called new devices that did not have the correct config register right from the factory .

Actions

This Discussion