Is there a way to set up a continuous MOH loop?

Answered Question
Mar 14th, 2007
User Badges:

I have a CM 4.1(3) system using Unicast MOH. Our source file is some marketing bitty-blah that the marketing department insists running in a loop. Trouble is, we don't have enough concurrent calls (ever) to keep the MOH source rolling, so every time someone gets put on hold they get the very first of the file. Transfers happen pretty quick around here, so almost 100% of the time, callers will just hear the (same) first three notes of the music and never get to the sacred gratuitous product placement.


Is there a way to keep the MOH "rolling" even if no users are currently on hold? That way, when someone does place a call on hold, the caller will hear the MOH source file at whatever point it happens to be in. I do have the "Play continuously (repeat)" box checked, but it appears that the MOH server starts from scratch upon the first call that gets put on hold.


I appreciate the help!

Correct Answer by dgahm about 10 years 1 week ago

Brian,

I think you are hearing silence because the multicast stream is not making it to the router. The default MRGL is using the unicast.


Go to CCM Admin under the MOH Server Config and scroll to the bottom under Selected Multicast Audio Sources and set the max hops to 10. The default 2 will not get you past the 1st router.


Then go back and change the gateway to use the correct Media List.


If you still get silence enter the following 2 commands on the gateway router:


show ip mroute 239.X.X.X (your multicast address)

show ip mroute 239.X.X.X count


Post the output.


Dave



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (6 ratings)
Loading.
dgahm Wed, 03/14/2007 - 12:35
User Badges:
  • Blue, 1500 points or more

Converting to multicast would surely do the trick.

support@eratema... Wed, 03/14/2007 - 13:28
User Badges:

Thanks for the reply - I tried that, but unless I had it configured incorrectly, it still played from the beginning of the source file. Starting with no current calls anywhere in the system, I called Phone A and put it on hold and let the music run for a minute. Then I hung up, called back, and repeated the procedure, but the file started from the beginning again.


Do the MOH servers only push the source content as long as at least one user is on hold?

dgahm Wed, 03/14/2007 - 14:08
User Badges:
  • Blue, 1500 points or more

The multicast source is always playing, even when no phones are on hold. I just confirmed this by watching the mroute packet count for a MOH multicast stream with no phones on hold.


We use a Muzak feed with multicast, but I will try a wav file and post the result.

dgahm Wed, 03/14/2007 - 14:48
User Badges:
  • Blue, 1500 points or more

Brian,

I just configured a recorded message as a MOH file, and set it for multicast. I set one test phone to use this for user hold. It did not start over, the caller that was placed on hold would alway hear a different starting point. This is on 4.1(3).


Did you have the phone that pressed hold configured for the multicast stream?


Please rate helpful posts.


Dave

Rob Huffman Thu, 03/15/2007 - 05:24
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Dave,


Nice thread here! It's always great to see someone go the extra mile and lab something up to answer a question. You surely get my 5 points on this one :)


Take care,

Rob

support@eratema... Thu, 03/15/2007 - 08:24
User Badges:

Hi, Dave:


Thanks so much! I tried it again, and I got it working for internal calls. Now when my test phones put each other on hold, they pick up wherever the MOH file happens to be.


Trouble is, when I call my test phones from the outside (through the gateway), the loop starts at the beginning. If I call the same phone from both the outside and inside and put both lines on hold, they are at different points in the MOH file. Any thoughts?


Brian

dgahm Thu, 03/15/2007 - 09:23
User Badges:
  • Blue, 1500 points or more

Brian,

What type of gateway is it? If MGCP, do you have this command?


ccm-manager music-on-hold


Is the router configured for multicast?


Dave

support@eratema... Thu, 03/15/2007 - 11:51
User Badges:

Dave:


Thanks again for all the help. I think I am really close. We're using a 2801 with MGCP, and we do have the "ccm-manager music-on-hold" command in the configuration (attached).


In the CCM Gateway configuration, when I assign the Media Resource Group List that I have designated for MOH, callers from the outside don't hear anything (not even the system's default 'three beeps') when placed on hold. Set the MRGL back to default, and the callers hear the appropriate MOH file - but it always starts from the beginning. Perhaps there is a setting somewhere that I am missing?


--Brian



Attachment: 
Correct Answer
dgahm Thu, 03/15/2007 - 16:01
User Badges:
  • Blue, 1500 points or more

Brian,

I think you are hearing silence because the multicast stream is not making it to the router. The default MRGL is using the unicast.


Go to CCM Admin under the MOH Server Config and scroll to the bottom under Selected Multicast Audio Sources and set the max hops to 10. The default 2 will not get you past the 1st router.


Then go back and change the gateway to use the correct Media List.


If you still get silence enter the following 2 commands on the gateway router:


show ip mroute 239.X.X.X (your multicast address)

show ip mroute 239.X.X.X count


Post the output.


Dave



support@eratema... Fri, 03/16/2007 - 14:47
User Badges:

Dave:


Thank you SO much. You were exactly right - my 2801 wasn't configured to handle the multicast stream. I set that up, and we now have our cheeky marketing loop running as promised.


Thanks again - I owe you one.


--Brian

Actions

This Discussion