Router 857w error configuration

Unanswered Question
Mar 14th, 2007

Hi all,

I am Daniel from Spain, trying to setting up my ADSL connection with out sucess.

Every single time that I am trying to configured by console an IP address for my new router fastethernet0\1\2\3 appear the following error; (% IP address may not be configured on L2 links).

I have erase the configuracion and also reseted the router for the manufacture values, but it did not help me at all.

I am not a router expert, and I appreciate if you tell me the procedures to fix this issue.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
jay.johnson1 Wed, 03/14/2007 - 17:15

I'm trying to set up my 871w right now and found the same problem. Basically, you "can not" assign an ip address to the LAN ports like a regular IOS router. Think of your 857 as being a "linksys wrt54g" on drugs. The porst on your 857w are equivalent to how the structure of a linksy SOHO router is (you can not assign separate ip addresses to them). The only internal ip addres allows initially is the one you set for the router.


flashsplash Thu, 03/15/2007 - 02:30

the error is refering to a layer two device/port make sure the interface u want to put the ip address on is a layer 3 interfaces.

can u post ur config so we can take a look at it...

ciao flash

jcorrale Thu, 03/15/2007 - 05:46

Hi Daniel,

The 857, 851, 871 and 877 routers come with 4-switch ports. Those ports are Layer 2 ports (like a small switch), so you can't configure an IP address. Those ports are managed by a single VLAN interface (interface Vlan1), so you can put the IP address on that interface but not on the FastEthernet port itself.

Hope it helps!



supergrip7 Fri, 03/16/2007 - 03:46

Hi Juan,

I am not able to configure my ADSL Router 857w, I was trying with same cisco configurations example and does not work.

I am from Spain my ADSL ISP is telefonica.

May I have ADSL Router 857w configuration with the information below?

Dynamic IP

Protocol PPPoE

VPI/VCI 8/32

Encapsulation mode LLC/SNAP

User xxx

Password xxx

DNS 80.x.x.250\254

I do not have router experience and I am in trouble with this configuration.

I will really appreciatte your support.

Thanks in advance.


supergrip7 Fri, 03/16/2007 - 09:35

Hi Ahmed,

I have tried with your configuration and I can not get to Internet yet.

However in the router front pannel appear a new light blinking:

OK - DATA (OK green light blinking)


the rest are the following (OK-CD-PPP are on in green with out blinking)

RXD - TXD blink sporadically.


Also I can ping router, but I can not ping my ISP DNS

Here I have attached the router conf, maybe I missed same important data.

Thanks a lot for your support.


supergrip7 Sat, 03/17/2007 - 03:07

Hi Ahmed

I do not what I am doing wrong, but the adsl connection still down.

I have change the configuration with the telefonica2.txt that you attached, and now in the front pannel router just the OK has the green ligth on, all the rest are off.

Attached the configuration.

Ahmed I am sorry for the inconvenience, and thanks a lot for your support.


supergrip7 Sat, 03/17/2007 - 13:52

Hi Ahmed

Let me let you know what happened after I introduce this part of the configuration on the router

interface ATM0.1 point-to-point

pvc 8/32

encapsulation aal5snap ppp dialer


% Invalid input detected at '^' maker

pppoe-client dial-pool-number 1

Here below is the telefonica ADSL configuration data link:



supergrip7 Sat, 03/17/2007 - 17:46



Just my wireless laptop does not reconized the wifi connection.

Thanks a lot for your support.

Here attached the config.


ahmednaas Sat, 03/17/2007 - 22:53

I am glad you got it working!

The working config looks like the original config I sent.


This Discussion