Meetingplace Express changing hostnames -***STICKY***

Unanswered Question
Mar 14th, 2007

I hope to use this thread to address problems with changing hostnames or domain names in Meetingplace Express server and web conferencing stops. I myself have called TAC on couple of occasions to fix this. I hope this thread will help users fix the problem themselves before calling into TAC.

When you change the hostname or domain name, a service called Breeze stops and will not let you login to the web interface of MPX. Voice conferencing is not affected by the hostname change. You can verify this by using command "mpx_sys status". THe output should say

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.7 (12 ratings)
rob.huffman Thu, 03/15/2007 - 06:43

Hi Sankar,

Thanks for posting up this most informative fix. Please take a moment to post a little answer on this thread as well so we can give you the nice rating this deserves :) It is so great when others here go "above and beyond"!

Thanks again,


thisisshanky Thu, 03/15/2007 - 08:32


Thanks for your kind words. This breeze service problem has been bugging me for atleast the last 3 installs for meetingplace express. My colleague had sent me the script files that he got from TAC to fix the problem. I read through the readme file and ran the scripts but never could successfuly run it without calling into TAC. One key thing to notice is that if you dont place the script files in a subfolder, the script never runs. It throws an error message saying "permission denied".

By the way, you are probably the first person in this forum who wants to help people out as well as appreciate posts from others and rate them. Its wonderful to have a resource like you in this forum!!


rob.huffman Thu, 03/15/2007 - 10:46

Hi Sankar,

Well, now the shoes on the other foot and I must Thank you for your kind words! I have enjoyed reading your posts very often and I have learned an enormous amount from you and many others as well. I always try to take a few minutes each week to rate the posts on the Forums and write a few words to let people know how much this all means to me. I feel very fortunate to be a part of something where people give so much of themselves.

Best regards!


PS - This type of post deserves far more than my 5 points!

matt.baumgartner Thu, 07/05/2007 - 00:12

I would like to echo Rob's comments above and also say a big thank you to Sankar! Another great post! Another 5 coming your way...



andrew.riley Thu, 07/05/2007 - 17:36


Worked through this with Matt and found that you need to do the following

1) run scripts as described in original post

2) set file permissions accordingly

3) create the following file in the sub folder. "set_breeze_hostname.log"

Step three was the deal breaker in getting around the 'permission denied'


thisisshanky Thu, 07/05/2007 - 17:48


Thanks for pointing that out. The last time I was doing the same procedure, the permission denied error was a bugger.I think the way we fixed it last time was to create a sub folder and then run the scripts from there. Dont remember having to create the log file. Anyways, good to know. Here is my 5 for you!!

rversluis Mon, 11/26/2007 - 22:13

The 2.0.2 upgrade changed the hostname in the upgrade process and made mpx unusable. The upgrade appended a to the MPX box's hostname.

I had to edit /etc/sysconfig/network by deleting the that was added and reboot the box to get it to have the correct hostname.

Unfortunately I think Tomcat still has the wrong hostname somewhere. When I try to go to the web page it redirects me to http://mpx.[DOMAIN]

Has anyone made it past this point?

mightyking Tue, 06/03/2008 - 17:02


Were you able to resolve the issue? If so, could you please let me know how you have done it? I am facing the same problem. When I try to go to the "http://Server_IP_address" the web page redirects me to "http://mpx.[DOMAIN].com/?redirected=true" and an error message stating "the web page can not be found gets displayed.

Any help would be much appreciated


rversluis Wed, 06/04/2008 - 04:06

after fixing the base hostname problem of the server, I had to fix the redirect to the proper hostname. It is located in this file:


the way to edit the file is to ssh to the mpx box, su - to root, edit the file with vim, find the hostname in this section and fix it, then save the file:

maxThreads="150" minSpareThreads="25" maxSpareThreads="75"

enableLookups="false" redirectPort="8443" acceptCount="100"

debug="0" connectionTimeout="20000"

disableUploadTimeout="false" proxyPort="80" proxyName="mpx.[DOMAIN].com"/>

mightyking Wed, 06/04/2008 - 06:51

There was an error with the domain name. Since I have corrected the name, I am able to access the MPE web page but when I launch the web meeting I receive an error stating " The Meeting Room could not connect to the cisco Unified MeetingPlace Express Server, please re-launch the Meeting Room or refresh your browser to resolve the connection" Everytime I laungh the web meeting I receive the above message. I guess it's looking for a particular port which is not probably open. Would you happen to know where the problem is?


rversluis Wed, 06/04/2008 - 09:48

Is this an initial install? If so, both ports on the box need an ip address, both need to have proper dns resolution, and breeze needs to be set up properly.

If it was working before, you upgraded it, and now it is not working, I don't know what would cause this issue. Breeze can often be the culprit. There are a number of fixes for breeze issues that are docemented elsewhere or can be provided by TAC.


This Discussion