Router CPU Utilization high (More then 98% )

Unanswered Question
Mar 14th, 2007

Dear All,

I am finding very high CPU utilization for cisco 3640 series router having version "c3640-io3-mz.124-12.bin"

Please find attached the SHOW PROC CPU command result. I could not figure out which process is taking this much CPU utilization, can any body help me to know how it is calculating.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
rajivrajan1 Wed, 03/14/2007 - 23:09

hi

ip input & syslog traps seems creating issue.

Check if debugging is on for anything.Therecould be lot of console msgs.do "u all"

And is there high rate of Bradcast inputs on any interface?

what abt the acls configured in ur router.

if possible post sho interface and configuration.

spremkumar Wed, 03/14/2007 - 23:10

Hi Arif

Check out for the following procesess IP input/syslog/snmp traps which is currently hogging up the cpu..

For ip input check whether you have CEF enabled on your router. if not you can enable the same using ip cef command under the global config mode.

IF CEF is already enabled make sure that you have genuine traffic being processed by your router.

you can enable cache flow to check out the traffic flow stats on your router.

enable ip route cache flow under your lan interface and check out for show ip cache flow command which will give you enough info the sessions/packets with source/destination ip address as well as port address..

For syslog you can disable all normal informative log messages and enable traps for alarming and the ones which require immediate attention..

regds

ilya.varlashkin Thu, 03/15/2007 - 14:20

the number after slash in 5sec utilisation is load due to interrupt handling (kernel/interface/line driver) and not specific process. See what level of traffic you have. Also check if you have some interfaces which are connected but not up. On 7200 platform high utilisation sometimes happens if there's unused (even admin down) POS interface with connected cable and activated interface on another side.

Doing netflow (not sampled) can also cause high cpu load due to interrupts. Config would be helpful.

aryan1980 Thu, 03/15/2007 - 21:39

Hi there..

1. with sniffer you can find out the route cause of your problem.

2. disable the http server and check.

hope this will help you to solve your problem.

regards,

aryan

Actions

This Discussion