Error disable on switch port

Unanswered Question
Mar 15th, 2007
User Badges:

Few of the ports on 3750 went in to error disable mode while configuring port channel.

config as goes

interface Port-channel1

switchport trunk encapsulation dot1q

switchport mode trunk


interface GigabitEthernet1/0/45

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

!

interface GigabitEthernet1/0/46

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on


GigabitEthernet1/0/49 is down; line protocol is down (err-disabled)


Also changed the cable but error remains the same.

Can?t restart the switch since its in live environment.


Any tips or suggestion highly appreciated.

Thanks.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
CSCO10892433 Thu, 03/15/2007 - 04:53
User Badges:
  • Silver, 250 points or more

Hi, mathiasivn


To manually reenable the port that is in err-disable state, simply issue "shutdown" then "no shutdown" on that port. However, the reason that cause err-disabled port is quite complicated. The following page may provide some help.


http://www.cisco.com/en/US/tech/tk389/tk621/technologies_tech_note09186a00806cd87b.shtml


HTH

SSLIN

Amit Singh Thu, 03/15/2007 - 05:04
User Badges:
  • Cisco Employee,

What is the config on the other side of the link. Check the logs and it will list to the cause for error disable. Most common in this case would be configration mismatch in terms of speed/duples, PAGP config.


Please paste the config og the other side.


Please follow the link paste by above poster for troubleshoot and recover the links.


-amit singh

Actions

This Discussion