cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
355
Views
0
Helpful
2
Replies

load balance outbound w/ NAT (router)

ferla
Level 1
Level 1

I want to make the balancing of outbound of two ISPs. I made the following configurations, but he did not function. somebody can help me?

int s0: ISP-1

int s1: ISP-2

eth0 10.10.10.1/24

mail server 10.10.0.2

proxy/ftp server 10.10.0.3

---------------------BEGIN--------------------------------

int eth0

ip address 10.10.0.10 255.255.255.0

ip nat inside

int s0

ip adress 200.100.200.2 255.255.255.252

ip nat outside

int s1

ip address 200.100.130.2 255.255.255.252

ip nat outside

ip route 0.0.0.0 0.0.0.0 200.100.200.1

ip route 0.0.0.0 0.0.0.0 200.100.130.1

ip nat inside source static 10.10.0.3 200.20.7.130 route-map ISP-1

ip nat inside source static 10.10.0.2 200.20.7.129 route-map ISP-1

ip nat inside source static 10.10.0.3 200.13.15.25 route-map ISP-2

ip nat inside source static 10.10.0.2 200.13.15.26 route-map ISP-2

access-list 101 permit ip 10.10.0.0 0.0.0.255 any

access-list 102 permit ip 10.10.0.0 0.0.0.255 any

route-map ISP-1

match ip address 101

set ip next-hop 200.100.200.1

route-map ISP-2

match ip address 102

set ip next-hop 200.100.130.1

---------------------END--------------------------------

thanks

Cleverson Ferla

2 Replies 2

vmoopeung
Level 5
Level 5

You need to specify what kind of traffic has to be translated when you are using, ip nat inside source static 10.10.0.3 200.20.7.130 route-map ISP-1

m.matteson
Level 2
Level 2

if you turn on CEF switching then your router should load balance per-destination across the routes you statically specified.

ip route 0.0.0.0 0.0.0.0 s0

ip route 0.0.0.0 0.0.0.0 s1

ip cef

if you want per-packet you can use the interface load-sharing command.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card