Urgent: One-way audio

Unanswered Question
Mar 15th, 2007

Having an issue. Seems intermittant, but often. Users are making or recieveing calls that they can hear the other party, but the other party cannot hear them. Sometimes it works when the call is terminated and retried, sometimes.

Recently upgraded CCM to 4.2(3) from 4.0(1)sr2a. Upgraded OS from 2000.2.6 to 2000.4.4a. Installed DST fixes, and device pack 4.2.3 (13).

CCM is MCS 7825, have a VG248 using 1.2(1), a 1760 on 12.3. I the IOS versions are older, but I want to check everything else before I start updating these.

Thinking it was the new phone loads, I downgraded the loads one version. It fixed one user and the number i tested with, but other users are still experiencing issues.

Should I downgrade the loads even more, or am I missing something else? I did the upgrading last week, but issue did not appear until today.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
jbarcena Thu, 03/15/2007 - 10:38

I really doubt that the phone load has something to do with this issue. Is the one way audio happening to all the calls (Internal and external) or just with the external calls?

It could be many things, routing issue that the GW is modifying the connection to an IP Address that the CCM server can not reach or perhaps a codec issue.

I would recommend you to take a CCM detailed trace to see what is exactly happening, other than this we will only be guessing and that is no way to troubleshoot an issue.


benharned Thu, 03/15/2007 - 10:41

It seems only external calls. According to the compatibility matrix, the IOS version listed for CCM 4.2(3) is 12.4(4)T. Seems all mine are 12.1. Could that be a factor?

I will try to do a trace though.

thisisshanky Thu, 03/15/2007 - 10:43

Simple test to make sure your you dont have any routing issues is to ping from the gateway to the phone subnet and also from the phone subnet (put a pc) to the gateway.

benharned Thu, 03/15/2007 - 11:42

I reupgraded a users phone load and dialed the number that I knew wasn't working before, and it stopped working again (it worked when I downgraded the load).

I ran a trace at the time, and didn't see any errors or anything, but I'm not totally sure what to be looking for. Or if I set the trace up right in the first place.

Any new suggestions? A different user I downgraded continues to have the issue with the lesser load. Should I downgrade the load even more? Should I look at upgrading the gateway IOS?

Tommer Catlin Thu, 03/15/2007 - 12:18

I would lean towards routing issues. One way audio is caused by mimatched codecs or routing issues between the vlans internally, switches, routers, gateways. CCM just sets up the call and drops out of the converstaion once the call is connected. If you have one way audio... its either of the above

benharned Thu, 03/15/2007 - 13:28

I've downgraded the loads even more and so far no issues.

I have a feeling it's a combo of load/router IOS. I am going to look at upgrading the IOS of the gateway and see if that maybe has any positive affect.

Tommer Catlin Thu, 03/15/2007 - 13:36

Try just reseting the MGCP gateways before doing all the upgrading, downgrading. Maybe they are just not working correctly. I have seen MGCP gateways fall out of registration, but still work. Then things like your problem creep up


This Discussion