CME not able tro transfer or park calls

Answered Question

Hello,

We're using CME 4.0(3) on IOS 12.4(4)XC6.

We're not able to transfer or park calls with other numbers INSIDE our dep. The transfer to outside numbers works regularly.

When we try to transfer or park calls, the active call is put on waiting (pause symbol on the phone), but then there is no way to transfer it. The fact strange is that the call is put to wait even with the park button...

Attached the partial config.

I'm quite desperate.

Thanks.

Attachment: 
I have this problem too.
0 votes
Correct Answer by Paolo Bevilacqua about 9 years 8 months ago

Good catch.

It's an ugly bug, but fixed in 12.4(11)T1, that is available on CCO. Can you try it?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Paolo Bevilacqua Sat, 03/17/2007 - 09:23

Hello, never be desperate.

can you configurean explicit pattern for internal transfers and call forward ?

Like:

transfer-pattern 5...

call-forward pattern 3...

remember that more than one pattern can be configured.

Paolo Bevilacqua Sat, 03/17/2007 - 10:23

The transfer-pattern defines to what numbers you are allowed to transfer numbers. The very first basic pattern that you set, is the one matching the extensions, four digits starting with 5 in your case.

Then, sometime you want to transfer to external lines, etc you so you add a wilcard, timeout terminated pattern.

True, the second should encompass the first, however for sanity check I would go step-by-step, define the basic transfer-pattern as above, and test before going for more complicated things.

Hello,

Thanks for the reply.

I think that I have found where is the problem (not solved again).

In this part of the config:

------------------------------

dial-peer voice 1 pots

preference 1

service script1

destination-pattern 0T

incoming called-number xxxxxxxx

direct-inward-dial

port 2/0

------------------------------

if I remove the "service script1" the call park and the call transfer work well!

But I need the IVR script...

I cannot understand how the script influences the call park and the call transfer...

Paolo Bevilacqua Sun, 03/18/2007 - 07:55

Hi,

Have you tried changing the transfer-pattern as I was suggesting before? Is it possible that the destination-pattern of dial-peer 1 matches your wildcard transfer-pattern and cause problems ?

I have more than one installation of CME with the B-ACD script as service under pots dial-peer, and all are able to transfer calls without problems (they don't use park for now).

So you can try configuring the default B-ACD script and instead of your custom one and see what happens.

Correct Answer
Paolo Bevilacqua Mon, 03/19/2007 - 05:05

Good catch.

It's an ugly bug, but fixed in 12.4(11)T1, that is available on CCO. Can you try it?

Actions

This Discussion