AIX 5.3/Cisco 6509 (IOS 12.2) and EtherChannel

Unanswered Question
Mar 19th, 2007

I'm trying setup EtherChannel's between five AIX hosts (2 x 1GB ports) and a 6509. We are unable to get (and keep) our the etherchannels running.

Here's a section of our Switch configuration for one of the the EtherChannels:

!

interface Port-channel22

description LACP port channel for mcc510d, g2/45 and g3/45

switchport

switchport access vlan 1001

no ip address

!

interface GigabitEthernet2/45

switchport

switchport access vlan 1001

mtu 9216

no ip address

channel-group 22 mode active

!

interface GigabitEthernet3/45

switchport

switchport access vlan 1001

switchport mode access

mtu 9216

no ip address

channel-group 22 mode active

!

interface Vlan1001

description Private VLAN mtu 9216

ip address 192.168.2.1 255.255.254.0

On AIX we are setting it as 802.3ad

Any help would be greatly appreciated!

-Kevin Burke

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
bbaley Fri, 03/23/2007 - 07:34

You have not specified the channel- protocol in the ports which contibutes to the port-channel

eg:-

hostname(config-if)channel-protocol lacp

kevindburke Fri, 03/23/2007 - 08:43

What's odd, is when I connect just the first 1GB adapter I get an aggregated connection. It only when I try to add the second 1GB adapter that things don't work.

I'll give your suggestion a try.

-Kevin

chrisklomp Wed, 08/13/2008 - 10:09

I'm having similar issue as Kevin.

And

channel-group 22 mode active

will set the protocol to LACP.

The channel-protocol line is implied.

However my issue is that I do get the AIX server and 6513 switch to etherchannel, until the VIOS (in the AIX server) reboots.

Then I have to shutdown and no shutdown the Portchannel, in order to reactivate the connection; (connection is broken and not non-channeled).

Anyone got this same issue and found a fix?

Actions

This Discussion