Wireless connectivity problem

Unanswered Question
Mar 19th, 2007

Hi Ahmed,

I am here again asking you to troubleshoot my connection.

Adsl is working perfectly, just I can not connect with my laptop, I mean it does not detect the SSID (Cisco) alredy configured on the 857w router.

Here I have attached the config, maybe you can take a look on it and see what is wrong.

Thanks in advance.

Daniel

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jcorrale Mon, 03/19/2007 - 15:10

Daniel,

Try adding the command "vlan 1" under the ssid Cisco:

ssid Cisco

vlan 1

:

And also, try to add the following command under the global config mode:

Router(config)# bridge 1 protocol ieee

Hope it helps!

Juan

supergrip7 Tue, 03/20/2007 - 03:11

Hi,

Just to let you know that I am still can not connect with my laptop to my 857w router wireless connection.

Thanks in advance.

Daniel

Paolo Bevilacqua Tue, 03/20/2007 - 03:43

I've seen this happening with 85x..

I think I had to erase configuration and start again, very strange. Will check a configuration that I have working later on.

jcorrale Tue, 03/20/2007 - 05:08

Hi Daniel,

Can you try this configuration:

interface Dot11Radio0

no ip address

!

!

encryption vlan 1 key 1 size 128bit 0 1234567890ABCDEF1234567890 transmit-key

encryption vlan 1 mode wep mandatory

!

ssid Cisco

vlan 1

authentication open

authentication shared

guest-mode

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0

channel 2462

station-role root

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no snmp trap link-status

no cdp enable

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$

no ip address

ip tcp adjust-mss 1452

bridge-group 1

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 10.10.10.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

bridge 1 protocol ieee

bridge 1 route ip

I have that configuration working in my Lab with an XP Laptop.

Hope it helps!

Juan

supergrip7 Tue, 03/20/2007 - 07:56

Hi Juan,

I have tried your configuration and unfortunally my wifi is still not working.

Let me attached my config, meybe to have the change to see what is wrong on it.

Thanks in advance.

Daniel.

jcorrale Tue, 03/20/2007 - 08:35

Hi Daniel,

Try changing the encryption mode to WEA instead of "ciphers tkip":

no encryption mode ciphers tkip

encryption vlan 1 mode wep mandatory

encryption vlan 1 key 1 size 128bit 0 1234567890ABCDEF1234567890 transmit-key

Make sure that you choose WEA on your Laptop and add the 128bit-key "1234567890ABCDEF1234567890".

Also, make sure you choose WPA as authentication method and to use the correct key. You can also try to use the WiFi without authentication for testing purposes:

SSID Cisco

no authentication key-management wpa

no wpa-psk

!

Finally, remove the following line from the main Dot11Radio0 interface:

no bridge-group 1

Let me know how it goes.

Regards,

Juan

supergrip7 Tue, 03/20/2007 - 09:32

Hi JUan,

Just to let you hnow that when I try to include the following line:

encryption vlan 1 key 1 size 128bit 0 1234567890ABCDEF1234567890 transmit-key

Error: key management does not support key index 1

Also when I try to include this one:

no authentication key-management wpa

Error: Encryption mode cipher is not configured.

I am not a router expert...

Thanks for your support.

Daniel

jcorrale Tue, 03/20/2007 - 10:02

Daniel,

I'm going to recreate your issue in my lab. I'll give you the results as soon as I finish.

Regards,

Juan

jcorrale Tue, 03/20/2007 - 10:12

Daniel,

I did the following changes to the last configuration you sent me and it worked on my XP Laptop:

interface Dot11Radio0

no bridge-group 1

no encryption mode ciphers tkip

encryption vlan 1 Mode ciphers tkip

!

Here is the configuration I'm using:

interface Dot11Radio0

no ip address

!

encryption vlan 1 mode ciphers tkip

!

ssid Cisco

vlan 1

authentication open

authentication shared

authentication key-management wpa

guest-mode

wpa-psk ascii 0 cisco123

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0

channel 2462

station-role root

no cdp enable

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no cdp enable

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 port-protected

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

no ip address

ip tcp adjust-mss 1452

bridge-group 1

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 192.168.1.254 255.255.255.0

ip access-group 102 in

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

!

bridge 1 protocol ieee

bridge 1 route ip

!

Let me know how it goes.

Regards,

Juan

supergrip7 Tue, 03/20/2007 - 14:56

Juan,

I have changed my configuration as following:

int Dot11Radio0

no ip address

no bridge-group 1

no encryption mode ciphers tkip

encryption vlan 1 Mode ciphers tkip

write memory

Then if I go to (show running-config) looks like it did not save properly because just appear

interface Dot11Radio0

no ip address

!

encryption vlan 1 mode ciphers tkip

!

ssid Cisco

vlan 1

authentication open

authentication shared

authentication key-management wpa

guest-mode

Also let you know that I do have HP laptop with a PCMCIA SMC2632W wireless card, and it was working properly with my old 3com Wireless router, I mean it inmediatly detected the wifi connection.

I do not what is happening with my router existing conf, I attached it again, in just in case you can detect samething wrong.

Thanks a lot for your support.

Daniel

jcorrale Tue, 03/20/2007 - 22:07

Hi Daniel,

I noticed that you have two different SSIDs configured (Cisco and cisco). Lets do the following:

no SSID cisco

ssid Cisco

wpa-psk ascii 0 cisco123

!

Now, if it doesn?t work after the changes, there should be something wrong with your Laptop configuration. Remember to change the WPA password/key on your Laptop to "cisco123" when connection to SSID "Cisco".

Hope it helps!

Regards,

Juan

Actions

This Discussion