RME: Using user defined groups in Compliance Checks

Unanswered Question
Mar 19th, 2007
User Badges:

I am using RME 4.0.5 on a windows 2003 system.


I am trying to set up a scheduled compliance check job against a small subset of our devices.


To this end, I have created a User defined group in CS (and also in RME) which contains these devices. I have checked that the group has been populated with the correct devices.


I can see this group when I do other tasks, but I cant see any groups when I try and create a Complaince Check job.


The tree under All Applicable Device Groups->User Defined Groups is empty. In other areas this contains my groups.


Is this a bug, or is there some configuration setting I need to change to get them to appear here?


Regards

Jeff

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Mon, 03/19/2007 - 17:17
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

A template is bound to one or more device types (e.g. Routers, Switches and Hubs, etc.). When you do a compliance check, you will only see devices in system or user defined groups which are part of the template's associated device group(s).


For example, I create a group in RME that ends up containing one 7206 router (group name is EEM Test Routers). I have a template, CredCheck, that is bound to the Routers device type group. I am able to see my router in my user-define group, EEM Test Routers when doing a compliance check.


Now, when I select a new template, NoCDPonAccessPorts, which is only applicable to the Switches and Hubs device type group, I no longer see any devices under my EEM Test Routers group during a compliance check.

Jeff Law Mon, 03/19/2007 - 19:57
User Badges:

I think I understand what you are saying here.


I have created a group called MyGroup (Attachment cwgroupadmin) which contains several routers.


I have created a compliance template called Test which has the overall category of Routers.


When trying to create the baseline job, I select the Test template and click on Compliance Check, but I dont see anywhere in the device selection area to select my group (attachment cwcompliancecheck). There are no User defined groups listed. I was expecting to find MyGroup listed so I could select it.


I would have thought I should be able to see MyGroup in the selection area. Is my expectation incorrect?



Jeff Law Tue, 03/20/2007 - 15:32
User Badges:

Ive attached a screen snapshot of my configuration.


I have tried various options but the results are still the same - no user groups appearing in the compliance check job....



Joe Clarke Tue, 03/20/2007 - 20:44
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

There seems to be a problem on your server. What is the current DCR mode of this server? Do you see any errors in the deviceselector.log when you try to do a compliance check?

Actions

This Discussion