Problems importing c2960-lanbasek9-tar.122-35.SE.tar into CW RME

Answered Question
Mar 20th, 2007
User Badges:
  • Bronze, 100 points or more

Dear All,


When trying to import IOS c2960-lanbasek9-tar.122-35.SE.tar into Cisco Works LMS RME's software repository I get the following error:


SWIM0009: Could not extract image attributes.

Check whether it is supported by Software Management.


I can import other IOS images such as c2950-i6k2l2q4-tar.121-22.EA9.tar without any problem.


Any ideas? Where does one check to see if a particular IOS image is supported by Software Management?


We are running LMS 2.6 with RME 4.0.5.


Craig

Correct Answer by Joe Clarke about 10 years 1 month ago

I sent it again, but it is most likely being filtered out. It is being sent to the email address tied to your Cisco.com account. Check your SPAM settings to make sure email from Cisco.com is allowed (at least temporarily).

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Tue, 03/20/2007 - 09:32
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

From where are you importing this image (e.g. file system, Cisco.com, etc.)?

Joe Clarke Tue, 03/20/2007 - 11:43
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I just downloaded c2960-lanbasek9-tar.122-35.SE.tar from Cisco.com, placed it on my file system, and imported it without errors. Perhaps you have a bad download. Try downloading it again, and give it a shot.

Craig Balfour Wed, 03/21/2007 - 05:46
User Badges:
  • Bronze, 100 points or more

I go our partners to download the file again and tried importing it again and got the same error message from RME.


Does Cisco provide MD5 checksums to verify the integrity of files?


If I md5sum the IOS file I have I get the following:


9b354d25b6a301b4827af474feb8ae75 c2960-lanbasek9-tar.122-35.SE1.tar


Any chance you could md5sum the file you have and see if it matches?


Alternatively the size of the file I have is 8.7Mb. Does this match the size of your file?


Craig Balfour Wed, 03/21/2007 - 05:57
User Badges:
  • Bronze, 100 points or more

Looks like our partner downloaded a different (later) IOS image the second time around - SE1 instead of SE. So the MD5 sum, etc I gave you above is for SE1, not SE, sorry.


RME is giving the same error when I try and import SE1 though.

Joe Clarke Wed, 03/21/2007 - 09:09
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I downloaded c2960-lanbasek9-tar.122-35.SE1.tar from Cisco.com, and I get a file with an md5 checksum of 0af32b107b48c18c787feac080e20c32 which a byte size of 9103360. Importing it from file system is successful.


The previous c2960-lanbasek9-tar.122-35.SE.tar had an md5 checksum of a0912b0c20612fbb0038688027231e94 and a byte size of 9103360.

Craig Balfour Wed, 03/21/2007 - 10:31
User Badges:
  • Bronze, 100 points or more

Since the checksums are different, I assume that there is a problem with the file our partner has downloaded.


They are going to deliver the file personally tomorrow (in case the problem occurred with the transfer via ftp from them to us). If CiscoWorks still doesn't like the file I'll get them to use their CCO credentials to import the file directly from Cisco.com into CiscoWorks.


Joe, thanks for your help.


Joe Clarke Wed, 03/21/2007 - 10:38
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I can post this image for you if need be.

Craig Balfour Thu, 03/22/2007 - 02:08
User Badges:
  • Bronze, 100 points or more

Our partner delivered the IOS images to us today but RME still gives the same error when trying to import them from the filesystem.


Here are the MD5 checksums (which, of course, differ from the ones you posted earlier):


4ad0e097cd200a760da53625cc501058 c2960-lanbasek9-tar.122-35.SE1.tar

b3f633975f53a7c314f762728900b8ab c2960-lanbasek9-tar.122-35.SE.tar


We also tried to important the SE1 image directly from Cisco.com but the job failed after 14 minutes or so with the following checksum error:


JOB ID - 1429 SUMMARY

----------------------------------------------------


Image Name : c2960-lanbasek9-tar.122-35.SE1.tar

Import status : Failed.


Total number of images to be imported to Software Repository : 1

Number of images imported : 0

Number of images failed : 1


Status of Job - FAILED.


Total time taken for Job - 14 Minutes 45 Seconds


-----------------------------------------------------------------------------------------------------


Start images downloading:


Image 1 of #1 :


Checking if image is present in the library...

c2960-lanbasek9-tar.122-35.SE1.tar is not present in the library.

Downloading c2960-lanbasek9-tar.122-35.SE1.tar from Cisco.com.

Start time: 22 Mar 2007 10:26:37

File downloaded successfully. Calculating MD5 checksum...

File downloaded successfully.MD5 checksum is failed.

-----------------------------------------------------------------------------------------------------


Joe, could I take you up on your offer to post the c2960-lanbasek9-tar.122-35.SE1.tar image?


Joe Clarke Thu, 03/22/2007 - 09:01
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I have published the image for you. You should be receiving an email on where to download it shortly. Note: you really should check your proxy/firewall to see if it is misconfigured or truncating these files.

Craig Balfour Fri, 03/23/2007 - 00:58
User Badges:
  • Bronze, 100 points or more

Hi Joe,


I haven't received the email yet. Can you try resending it.


I don't think the firewall / proxy problem is on our end. We don't have direct access to download stuff from CCO and rely on our partners to do the download and then pass the files on to us. I suspect that the problem lies with them.


Correct Answer
Joe Clarke Fri, 03/23/2007 - 09:26
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I sent it again, but it is most likely being filtered out. It is being sent to the email address tied to your Cisco.com account. Check your SPAM settings to make sure email from Cisco.com is allowed (at least temporarily).

Craig Balfour Fri, 03/23/2007 - 12:14
User Badges:
  • Bronze, 100 points or more

That worked. I successfully download the image and MD5 checksums matched. I imported the image into CiscoWorks without any errors.


Joe, thanks for your help. It is much appreciated.

Actions

This Discussion