Internal Caller Display

Unanswered Question
Mar 20th, 2007

Hi,

Is there anyway with Call Manager 4.1(3) where you can prevent your number from being shown when placing internal calls (without the need for a second line)?

So if Bob on 4444 calls Jane on 5555, only 'bob' shows up rather than 'bob 4444' on Janes LCD screen.

Any help is much appreciated. Thanks,

Mike

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (3 ratings)
Loading.
lfulgenzi Tue, 03/20/2007 - 06:00

From: http://forums.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Unified%20Communications%20and%20Video&topic=IP%20Telephony&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.1dddc680

There is no 'line' level configuration option to do what you are asking. This is one of those things that Cisco wants you to do with partitions and calling search spaces.

Essentially, you set up a partition called PrivateCaller_PT and a search space called PrivateCaller_CSS.

Create a translation that matches your internal dialplan, say 4XX if you only have 3digit extensions that start with 4, and in the calling party transformation parameters Calling Line ID Presentation & Calling Name Presentation set to Restricted.

This will achieve what you are looking for, in principle, anyways.

In the past you would have to add additional translation patterns with more precise DNs to 'not block' calling ID to specific numbers, i.e. security, however, they have added the "Ignore Presentation Indicators (internal calls only)" parameter on the device which will ignore the translation pattern.

You wil find that you will be doubling up on your calling search spaces in order to achieve this. For example, if you have 6 calling search spaces for your area, you have the potential of someone in each calling search space not wanting to display their calling ID.

See how that works and let us know.

Lelio

Don't forget to rate helpful posts.

Actions

This Discussion