CME question

Unanswered Question

Hi,


Can Cisco CME to act as the DSP farm host for MTP resource?

I know it's OK for transcode and conference resource. But It's not successful with MTP resource.


===============


SiteB#sh sccp

SCCP Admin State: UP

Gateway IP Address: 10.30.41.1, Port Number: 2000

IP Precedence: 5

User Masked Codec list: None

Call Manager: 3.3.3.3, Port Number: 2000

Priority: 2, Version: 3.1, Identifier: 333


Transcoding Oper State: ACTIVE - Cause Code: NONE

Active Call Manager: 3.3.3.3, Port Number: 2000

TCP Link Status: CONNECTED, Profile Identifier: 1

Reported Max Streams: 12, Reported Max OOS Streams: 0

Supported Codec: g711ulaw, Maximum Packetization Period: 30

Supported Codec: g711alaw, Maximum Packetization Period: 30

Supported Codec: g729ar8, Maximum Packetization Period: 60

Supported Codec: g729abr8, Maximum Packetization Period: 60

Supported Codec: gsmfr, Maximum Packetization Period: 20

Supported Codec: g729br8, Maximum Packetization Period: 60

Supported Codec: g729r8, Maximum Packetization Period: 60

Supported Codec: rfc2833 dtmf, Maximum Packetization Period: 30


Software MTP Oper State: ACTIVE_IN_PROGRESS - Cause Code: NOT_REGIS_WITH_CCM

Active Call Manager: 3.3.3.3, Port Number: 2000

TCP Link Status: CONNECTED, Profile Identifier: 3

Reported Max Streams: 4, Reported Max OOS Streams: 0

Supported Codec: g711ulaw, Maximum Packetization Period: 30

Supported Codec: rfc2833 dtmf, Maximum Packetization Period: 30


Conferencing Oper State: ACTIVE - Cause Code: NONE

Active Call Manager: 3.3.3.3, Port Number: 2000

TCP Link Status: CONNECTED, Profile Identifier: 2

Reported Max Streams: 8, Reported Max OOS Streams: 0

Supported Codec: g711ulaw, Maximum Packetization Period: 30

Supported Codec: g711alaw, Maximum Packetization Period: 30

Supported Codec: g729ar8, Maximum Packetization Period: 60

Supported Codec: g729abr8, Maximum Packetization Period: 60

Supported Codec: g729r8, Maximum Packetization Period: 60

Supported Codec: g729br8, Maximum Packetization Period: 60

Supported Codec: rfc2833 dtmf, Maximum Packetization Period: 30


Software MTP Oper State: ACTIVE_IN_PROGRESS - Cause Code: NOT_REGIS_WITH_CCM

Active Call Manager: 3.3.3.3, Port Number: 2000

TCP Link Status: NOT_CONNECTED, Profile Identifier: 4

Reported Max Streams: 4, Reported Max OOS Streams: 0

Supported Codec: g729ar8, Maximum Packetization Period: 60

Supported Codec: rfc2833 dtmf, Maximum Packetization Period: 30


SiteB#

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
PETER NEGUS Tue, 03/20/2007 - 08:52
User Badges:

I seem to remember that you cannot register an MTP to CME. As you are probably aware, the XCODER is a sort of super MTP, so XCODERS will do the job of an MTP, abeit rather inefficiently.


If you are using CME 3.4 or less, you need "transfer-system full-consult" under your config to do consultative transfers etc.

Miguel Angel Es... Tue, 09/10/2013 - 22:29
User Badges:

Do you have some document or release notes that I can support this comment: That I cannot register an MTP to CME, because my client said that He already register a MTP in a CME version 6.x, so I need to sustain that!

Jorge Armijo Thu, 09/12/2013 - 19:47
User Badges:
  • Silver, 250 points or more

Miguel,


-There's no such thing as CME 6.x:

http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/requirements/guide/33matrix.htm


-Regarding the MTP question, I couldn't find any external documentation, but if you read the CME admin guide:

http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/admin/configuration/guide/cmeadm.html


-You'll find nothing about MTP configuration on CME, that means is not supported, or in other words, not needed.


-Finally, there is a MTP command that you can use for IP Phones registered to CME:

http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/command/reference/cme_m1ht.html#wp1108535


mtp

To send voice packets from an IP phone to the Cisco Unified CME router, use the mtp command in ephone or ephone-template configuration mode. To return to the default, use the no form of this command.


mtp {video-only | both}

no mtp {video-only | both}


Usage Guidelines


Normally, media packets (RTP packets) that are sent between IP phones in  the same Cisco Unified CME system go directly to the other phone and do  not travel through the Cisco Unified CME router. When these packets are  sent from a remote IP phone to another IP phone in the same  Cisco Unified CME system, they may be obstructed by a firewall. The mtp command instructs a phone to always send its media packets to the  Cisco Unified CME router, which acts as a proxy and forwards the packets  to the destination. Firewalls can then be easily configured to pass the  RTP packets because the router uses a specified UDP port for media  packets. In this way, RTP packets from remote IP phones can be delivered  to IP phones on the same system. The default is that this function is  off and that RTP packets that are sent from one IP phone to another IP  phone in the same Cisco Unified CME system go directly to the other  phone.


If you use an ephone template to apply a command to a phone and you also  use the same command in ephone configuration mode for the same phone,  the value that you set in ephone configuration mode has priority.


HTH


--
Jorge Armijo

Please remember to rate helpful responses and identify helpful or correct answers.

Jorge Armijo Fri, 09/13/2013 - 10:09
User Badges:
  • Silver, 250 points or more

Miguel,



Yes, same thing for CME 9



HTH


--
Jorge Armijo

Please remember to rate helpful responses and identify helpful or correct answers.

asset.imatayev Fri, 06/12/2015 - 12:29
User Badges:

on CME 8.6 works.

1) under telephony-service enable auto-reg-ephone

2) under telephony-service increase  max-ephones 

Actions

This Discussion