Telco dropping calls from analog gateway

Answered Question
Mar 20th, 2007

We just changed carriers for our two PRI's. Since then our outbound only fax (analog) calls do not connect. We get a fast busy signal. We have worked with the carrier and they are getting the call but their switch is dropping the call. They said our analog calls come in as 3.1KHz audio and the non-analog calls work but they hit the carrier as "speech". The other issue they say it "might" be is that our analog "Calling_Num" is type and plan "unknown". Whereas the digital calls that work the "Calling_num" ISDN/telephony. Any ideas on how to get this changed or should the carrier be able to handle this?

I have this problem too.
0 votes
Correct Answer by Paolo Bevilacqua about 9 years 8 months ago

I think you should show this last trace to telco and ask how do they really want the call to be.

The succesfuk one, incoming, has bearcap 3.1KHz and called type/plan ISDN/unknown. Perhaps they want it that way. Perhaps they want all nine digits for local calling too.

I have not seen a trace of a succesful call from IP phone to the smae number, else I would compare to that as well.

By now I think you have understood how to change the call parameters.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Paolo Bevilacqua Tue, 03/20/2007 - 15:36

These parameters are easy to change. Tell us which gateway you have, and if you are using MGCP h323, which CCM release if you are using it. Someone on the forum can suggest how to configure.

g.chavez Tue, 03/20/2007 - 15:39

We have a 2650 router with (2) 2-port FXO cards. We are using CCM 4.0. I believe we are using MGCP h323 but am not sure how to confirm.

Paolo Bevilacqua Tue, 03/20/2007 - 15:49

Hi,

There is nothing you can change in FXO ports. Before you mentioned PRI and things that are ISDN, where are these?

g.chavez Tue, 03/20/2007 - 15:52

Our PRI's come in on a 3745 router. We have two CCM servers and the 2650 router with the FXO cards for use as the analog gateway.

Paolo Bevilacqua Tue, 03/20/2007 - 16:00

Ok, all the things telco said (3.1 Khz/speech/numbering type and plan) apply to PRI only. If you have problems with these, we can help you change the parameters.

On the FXO ports there is nothing you can change, and if telco is complaining about the things above said on analog lines, either there is a gross misunderstanding, or they are taking you for a ride. FXO ports are the one that go into the wall plug, that is telephone lines.

Perhaps you mean the fax machines are connected to FXS ports ?!?

g.chavez Tue, 03/20/2007 - 16:04

Let me clarify. We are using channels on their PRI to send analog calls. We do not have any 1FB(analog) lines from the Telco. All inbound fax and digital call work. All outbound digital calls work. All calls go thru the PRI. However, outbound faxes are leaving our network and are being received by the Telco on the PRI. But they are being received as 3.1 audio format. Outbound analog calls are the only thing that is not working. I assumed that changed would be on the 2950 since that is our analog gateway. That gateway must somehow route back to the 3745 to go outbound on the PRI. Make sense?

Paolo Bevilacqua Tue, 03/20/2007 - 16:11

Ok, so the 2950 has 4 FXS ports connected to fax machines, correct ?

Now, depending on how the two routers and the CCM are configured, there can be more that one place to apply the changes to bearer capability (the 3.1 / speech parameter) and the plan type (the unknown/isdn parameter).

If you are unsure if using MGCP or h.323, post configuration, omitting public IP and telephone numbers, and someone can suggest the best thing to do.

Paolo Bevilacqua Tue, 03/20/2007 - 17:02

OK. Indeed you have 4 FXS ports in the 2950 and are using h.323. The routers are quite accurately configured.

In the 3745, under serial 4/0:23 and 4/1:23 configure:

isdn outgoing-voice info-transfer-capability speech

and if calls still not going out:

isdn map address . plan isdn type national

Note: for the latter, make sure with telco that this is actually what they want for ALL calls. If your ability to place international calls is impacted by this, there are other configurations that can be done.

You can verify what parameters are in the call doing "term mon" and "debug isdn q931". With this, you will see also why telco is refusing the call.

Hope this helps, if so please rate post!

g.chavez Wed, 03/21/2007 - 07:43

I entered the first command and do a show run but it does not show up and it still rings busy so I am not sure if it displays in the config or not? Any ideas?

Paolo Bevilacqua Wed, 03/21/2007 - 09:02

hi,

the config should show up, try again. then the debug command above and "term mon" will tell you how is working.

g.chavez Wed, 03/21/2007 - 09:07

I did that and it still shows as an audio call instead of speech and it doesn't show on the config. the switch type is DMA-100. Could that have something to do with it?

Paolo Bevilacqua Wed, 03/21/2007 - 09:41

I think is not being configuring correctly. Are you familiar with "config terminal" mode ?

g.chavez Wed, 03/21/2007 - 09:50

I am. Here is what I entered.

Config t

int ser 4/1:23

isdn voice .... speech (the command you gave me).

I repeated this for int ser 4/0:23

It returns to the #prompt.

Exit (twice) to get back out of config mode.

Then show run and it is not there.

Paolo Bevilacqua Wed, 03/21/2007 - 11:37

Hi. You are correct, the command does not show because is the default. There is another way to force bearer capability:

voice-port 4/0:23

bearer-cap speech

voice-port 4/1:23

bearer-cap speech

This time should show in config and achieve the desired change.

g.chavez Wed, 03/21/2007 - 12:40

Entered the commands and it took them all. It still does not show up on "show run" and it still gets a fast dial and does not complete the call.

g.chavez Wed, 03/21/2007 - 14:35

Correction. I does show up in the "show run". It was just in a different spot than I anticipated but it is there. However the calls still do not go through (fast busy). Carrier would also like us to change so analog calls "Calling Party number plan" is not "unknown". On a digital call that works, this field say "ISDN/telephony" and the "Called_num" field says "unknown". The fax calls that don't work are the opposite of this. Can you help change the Calling_ Num Numbering plan?

Paolo Bevilacqua Wed, 03/21/2007 - 15:16

Hi,

To change calling type and plan, you need a this:

voice translation-rule 10

rule 1 // // type any national plan any isdn

voice translation-profile setplan

translate calling 10

voice-port 4/0:23

translation-profile outgoing setplan

note: there is no type "telephony" in the config options. types are:

abbreviated Abbreviated numbering type

international International numbering type

national National numbering type

network Network numbering type

reserved Reserved numbering type

subscriber Subscriber numbering type

unknown Unknown numbering type

To confirm all changes, please post output of "debug isdn q931" when making a call.

g.chavez Thu, 03/22/2007 - 10:53

Still not changing the caller type. I am not sure if the rule is right. I typed it in literally. Look at the log below. We want the calling number plan to mat no auto-summary

Attachment: 
Paolo Bevilacqua Thu, 03/22/2007 - 11:43

Hi, should be configured correctly.

Now try to capture one outgoing call from fax.

If that doesn't work, the same translation-profile can be applied to dial-peers pots too.

The one you attached is an incoming call, someone calling extension 3115.

g.chavez Thu, 03/22/2007 - 12:11

OK. We added the translation plan to dial-peer 9 pots as well. It looks like the dial plan changed but not the type. See below:

Mar 22 19:08:29.399: ISDN Se4/1:23 Q931: TX -> RELEASE pd = 8 callref = 0x1915

Mar 22 19:08:29.419: ISDN Se4/1:23 Q931: RX <- RELEASE_COMP pd = 8 callref = 0x

9915

Mar 22 19:08:29.771: ISDN Se4/1:23 Q931: Applying typeplan for sw-type 0x5 is 0x

2 0x1, Calling num 2084553122

Mar 22 19:08:29.771: ISDN Se4/1:23 Q931: Applying typeplan for sw-type 0x5 is 0x

0 0x1, Called num 3218555

Mar 22 19:08:29.771: ISDN Se4/1:23 Q931: TX -> SETUP pd = 8 callref = 0x191B

Bearer Capability i = 0x8090A2

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98395

Exclusive, Channel 21

Progress Ind i = 0x8183 - Origination address is non-ISDN

Calling Party Number i = 0xA1, '2084553122'

Plan:ISDN, Type:National

Called Party Number i = 0x81, '3218555'

Plan:ISDN, Type:Unknown

Mar 22 19:08:29.811: ISDN Se4/1:23 Q931: RX <- CALL_PROC pd = 8 callref = 0x991

B

Channel ID i = 0xA98395

Exclusive, Channel 21

Mar 22 19:08:29.815: ISDN Se4/1:23 Q931: RX <- PROGRESS pd = 8 callref = 0x991B

Cause i = 0x829C - Invalid number format (incomplete number)

Progress Ind i = 0x8288 - In-band info or appropriate now available

Mar 22 19:08:30.615: ISDN Se4/0:23 Q931: TX -> CONNECT pd = 8 callref = 0x9330

Mar 22 19:08:30.675: ISDN Se4/0:23 Q931: RX <- CONNECT_ACK pd = 8 callref = 0x1

330

Police3745#te

Mar 22 19:08:32.991: ISDN Se4/1:23 Q931: TX -> DISCONNECT pd = 8 callref = 0x19

1B

Cause i = 0x8090 - Normal call clearing

Mar 22 19:08:33.067: ISDN Se4/1:23 Q931: RX <- RELEASE pd = 8 callref = 0x991B

Mar 22 19:08:33.071: ISDN Se4/1:23 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x

191Brm nomon

^

g.chavez Thu, 03/22/2007 - 12:23

I take that back. It looks like the calling type did change. This looks like what the Telco wants but they are still coming back with incomplete number. What are you seeing from this?

Correct Answer
Paolo Bevilacqua Thu, 03/22/2007 - 13:09

I think you should show this last trace to telco and ask how do they really want the call to be.

The succesfuk one, incoming, has bearcap 3.1KHz and called type/plan ISDN/unknown. Perhaps they want it that way. Perhaps they want all nine digits for local calling too.

I have not seen a trace of a succesful call from IP phone to the smae number, else I would compare to that as well.

By now I think you have understood how to change the call parameters.

g.chavez Thu, 03/22/2007 - 15:46

Had to enter another rule for "called" plan "unknown unknown" and then added to the setplan. This now works.

Thanks SO MUCH for your help!

Greg

Actions

This Discussion