2801 4 PPPOE-Client Hwic-4esw

Unanswered Question
Mar 20th, 2007


I have four adsl connections to my isp and I would like to be able to

replace my current cisco 2621 router and my four linux dsl routers with

one cisco 2801 router & one hwic-4esw.

I have got one connection to my isp working on the hwic by putting the pppoe-client command on a vlan. This seems to work but it is always saying that the virtual-access1 interface is going up and down all of the time. I also cannot get the router to route traffic through that connection but i can ping out to the internet from the router. I have tried some things with route-maps but nothing seems to work.

I cannot use the: ip virtual-reassembly command either as stated in other posts when doing pppoe on an hwic:


Also, is it possible to have more than one pppoe-client connection on the same router because there can only be two virtual-access interfaces? Is this a limitation of the ios ,the router or the hwic?

2801 - ip base - 12.4(1c)



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
jcorrale Tue, 03/20/2007 - 22:30

Hi Dan,

The problem here is that you have an Ethernet-Switch module, so this is not a pure Layer 3 module but Layer 2. That means that you?ll need to create a VLAN interface and link that VLAN to each FastEthernet port to configure 4 different PPPoE circuits. Unfortunately, the VLANs don?t have all the Layer 3 capabilities of an Ethernet/FastEthernet interface, and that?s why you can start seeing issues with your PPPoE circuits. Can you please provide the configuration?



Paolo Bevilacqua Wed, 03/21/2007 - 04:21

Hi Jcorrale,

I got curious about this and tried to no avail with 12(4)11T1. Created multiple vlans, mapped one single port to each vlan, configure the vlan interface with pppoe-client and different dialer-pool-groups,to no avail. Only one virtual-acess interface of type "base pppoe" gets created. A second interface of type "base vrtmgr" gets then created".

After I'v experimented with vpd-groups, bba-groups and virtual tmeplates - nothing works.

I think these is some issue in having multiple pppoe clients in current IOS.

jcorrale Wed, 03/21/2007 - 07:13


This is a hardware limitation of the HWIC-4ESW card and not the IOS version because I can create two or more PPPoE circuits with two or more WIC-1ADSL/HWIC-1ADSL cards.

As I told you before, the HWIC-4ESW is a switching module and not a Layer 3 card.



Paolo Bevilacqua Wed, 03/21/2007 - 11:21


I don't think this is the correct explanation and I will explain why.

When you configure each port into a separate VLAN, the router will handle each port at L3. Effectively, you will have 4 or 9 fully routed ports.

Now, if the IOS software has a confused idea of the real module capabilities when configuring multiple vlan's, this is another issue.

It is very legitimate to expect each port of this type of module to be able to support a separate pppoe client.

jcorrale Wed, 03/21/2007 - 12:10


That card is a Layer 2 card that can be configured with some (not ALL) Layer 3 capabilities. I?ve been working with Cisco DSL TAC for more than 2 years and I?ve seen a lot of issues when using a non-Layer 3 port to connect an external ADSL modem. You can use that card to support routing (Layer 3) functions but it doesn?t mean that you can run all the Layer 3 features you can run with a Ethernet/FastEthernet card.

I understand your point but due to my experience in DSL, I won?t suggest creating a PPPoE connection using a Vlan interface. This can cause unexpected behavior.



Paolo Bevilacqua Wed, 03/21/2007 - 14:55


I've been with cisco 8 years.. last 4 as tme for the 7200.

I think in this case there is a software limitation in IOS that has nothing to do with the hardware. The cause can be in the module drivers or in the pppoe code inability to drive it, this I don't know.

If I have time, I will try to configure multiple pppoe clients on 802.1q subinterface for the built-in LANs. If it works, at least one can fan-out these to the broadband bridges with a switch.

jcorrale Wed, 03/21/2007 - 15:00


That sounds good. Let me know if it works for you.



Paolo Bevilacqua Wed, 03/21/2007 - 17:20

Even worst, pppoe-client cannot even be configured for dot1q subinterfaces.

This is striking. When doing performance testing for the 7200, I used to bring up thousands of pppoe clients on a box. But we were using a special image to do that.

danletkeman Wed, 03/21/2007 - 20:02

I did try using sub interfaces first before I got the hwic card and that didn't work for me either.

So if I have this right, it should work on the hwic, but there might be a problem?

Is there any other solution available for around the same cost?

Thanks for replying,


jcorrale Thu, 03/22/2007 - 05:37

Hi Dan,

That is correct, it can work with the HWIC but you'll see issues like connection drops or latency, or even worst, no connection at all.

You can install 1 additional FastEthernet port using the HWIC-1FE, the 2801 supports just 1 of this type of card.

There is another card called HWIC-2FE, which give you 2 FastEthernet ports but unfortunately it is not supported on the 2801 but on the 3825 or 3845 you can install 2 of this type and will have 4 Layer 3 ports that can do PPPoE without any issues.


Hope it helps!




This Discussion