FXO call disconnect problem

Unanswered Question
Mar 20th, 2007

Network setup: ISR 2821, CCME4.1, pvdm2-32, Configured dsp for hardware conferencing


Whenever an outgoing call is made, and is rejected by the external party, The FXO port is not disconnected, it does not free up the port for new incoming/outgoing call.

A manual shut and no shut is done on the voice ports when this problem arise.


We tried to set it to groundstart. Battery reversal. with supervisory disconnect, but to no avail.

*note* However this is not a problem when the IP phone user terminates the call instead

Plz advise

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Paolo Bevilacqua Wed, 03/21/2007 - 09:18

And with hardware conferencing disabled works? That is very strange. What do you mean by rejected, who did initated the call?

J_Vansen_S Wed, 03/21/2007 - 23:00

Sorry for the confusion. Whether or not hardware conferencing is enabled, it does not affect the outcome. It still hangs

Anyway i tried out using


voice class custom-cptone test

dualtone busy

frequency 400 400

cadence 375 375

dualtone disconnect

frequency 400 400

cadence 375 375


voice-port 0/0/0

supervisory disconnect dualtone mid-call

supervisory custom-cptone test


This works for me. I suppose it has to be precise with the frequency coordinated with the PBX/PSTN

Ground start and battery reversal does not help in solving this issue. So we are down to using tone supervisory to disconnect the call.

Thanks for all of your inputs

shane.orr Wed, 03/21/2007 - 11:02

I have had a bunch of locations with Supervision Disconnect Problems. How I test to see if it is a problem for me is to call inbound from my cell, wait till it starts ringing my Directory Number, hang up my cell, and the IP Phone still rings for quite a while or potentially indefinitely. Short of switching to groundstart I followed all the docs trying to resolve this problem. All I do now to fix thus far is to call Telco and have them enable "Fast Disconnect" I have had the most problems when connecting to a DMS100 Telco Switch. This has resolved %90 of my no disconnect issues. Not sure if this is applicable to you but hope it helps....

Paolo Bevilacqua Wed, 03/21/2007 - 11:40

shane, correct.

However these is a big responsibility on the IOS software in these problems as well.

You call from outside and hang up before answer.

Without any doubt the line from C.O. will stop sending ringing current with seconds.

That the router/IOS fails to detect that ringing has ceased and let the IP phone ring, it's a bug in itself.


This Discussion