Dial-peer preferences

Unanswered Question
Mar 21st, 2007
User Badges:

We have a customer who is having problems with dial-peer preferences. Customer has two CallManager servers, so there are two voip dial-peers configured on the router. One pointing the subscriber with a default preference of 0 and one pointing to the publisher with a configured preference of 5. The problem is when the subscriber is off-line, the dial-peers don?t fail-over at all. A TAC case was opened and Cisco was able to reproduce this in their lab.

My question is has anyone else seen this and if so, how did you fix it? Cisco told us to upgrade all of the routers. Would really like to find a way not to have to do that.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Loading.
mparekh Wed, 03/21/2007 - 07:33
User Badges:
  • Bronze, 100 points or more

You may need to add the following commands:

voice class h323 1

h225 timeout tcp establish 3


Then under the dial-peer add this command:

voice-class h323 1


essentially, this tells the gateway if the call is not established in 3 seconds use the next dial-peer.


http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121newft/121t/121t2/dtcfgtim.htm

Chris Deren Wed, 03/21/2007 - 07:35
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,
  • Cisco Designated VIP,

    2017 IP Telephony, Contact Center, Unified Communications

Add this:

voice class h323 1

h225 timeout tcp establish 3


and then apply the voice class to the dial-peers.


HTH,


Chris

chris.damore Wed, 03/21/2007 - 07:53
User Badges:

These commands have were added. I should have stated that in my original post.

Any other ideas???

Thanks,

Chris

paul.higgsboyo@... Wed, 03/21/2007 - 08:05
User Badges:

I would be more specific with your dial-peer preferences. Make the default one have a preference of 1 and the backup a preference or 2. This is how I set all mine up and dont have a problem.


You may well be hitting a bug on the IOS version your running. Try upgrading one gateway and see how that works out.

j-schulze Wed, 03/21/2007 - 11:58
User Badges:

This might be worth a shot. The dial-peer with "DOWN" outbound status will not be selected during the outbound dial-peer matching. This affect no outgoing call setup on the BRI interface.


Define "no dial-peer outbound status-check pots" to by-pass the dial-peer outbound status check.




paolo bevilacqua Wed, 03/21/2007 - 12:04
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

j-s,


But the issue is with voip dial-peer, not pots.

j-schulze Wed, 03/21/2007 - 12:12
User Badges:

p.b.


you are correct sorry didn't read the issue correctly.

dsobrinho Wed, 09/18/2013 - 13:52
User Badges:
  • Red, 2250 points or more

Hey guys,


I have faced the same problem. We have two gateways 3925 with IOS version

c3900-universalk9-mz.SPA.152-4.M2.bin


There are two Controllers E1 with one PSTN service connected. Recently whe have activated a ISDN PRI in each Gateway, but when I set a preference in the dial-peer to be  second option for call flow all calls change and assuming the second peer as outgoing trunk.


The second Link was a backup PSTN in case of problem with First.


Best regards,

Daniel

Actions

This Discussion