Console Time showing incorrectly

Unanswered Question
Mar 21st, 2007
User Badges:

I am consoleing into a 1800 seris router.

If i do a show clock it shows the correct time. When i see events being logged on the console (IE: a link going up/down) It shows the time as incorrect. It is not applying the correct timezone. Example.

If a link goes down right now (12:50PM)

the console will log the up/down time as 16:50

If do a show clock the time will be 12:50


How do i fix this?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
mahmoodmkl Wed, 03/21/2007 - 10:33
User Badges:
  • Gold, 750 points or more

Hi


check weather this is configured in ur router.


service timestamps debug datetime

service timestamps log datetime


Thanks

Mahmood

Richard Burts Wed, 03/21/2007 - 10:51
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Michael


While it is a good thing to do, the service timestamps debug does not relate to the issue that you describe since it controls the timestamps for debug output.


I believe that the answer is in service timestamps log as Mahmood has suggested. And I believe that you probably already have service timestamps log datetime configured, because if you did not the log messages would report uptime rather than clocktime. But I believe that it is not enough to configure service timestamps log datetime. I believe that you need to include the localtime parameter, especially if you are learning time from NTP. So it would be service timestamps log datetime localtime.


HTH


Rick

mikegrous Wed, 03/21/2007 - 11:05
User Badges:

service timestamps log datetime localtime


was the command i needed.

I already had "service timestamps log datetime" configured. I needed the localtime command added.


Thanks alot.

Actions

This Discussion