WAN load balancing and failover

Unanswered Question
Mar 22nd, 2007

I have subscribed two broadband links from the same ISP for connecting branch office to the head office. I am using Cisco2600 router at the branch and it has two ethernet interfaces. I am planning to use the two WAN links by configuring one ethernet port with two Ip addresses (using secondary address), is it possible Or could you please suggest another option for using the two links?

Thank you

tigist

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
owaisberg Thu, 03/22/2007 - 11:44

Another option would be to use trunking

on that interface and create two

subinterfaces,each will represent a link to different ISP.


HTH,

OW

tigist_abe Thu, 03/22/2007 - 22:58

The ISPs devices for the two broadband WAN links are cisco UBR900 and Cisco soho AdsL.

The Cisco 2600 router that is found in the branch, one interface is configured for the branch network. I am having problem in configuring the second interface with two Networks (using secondary IP). I have already configured it with secondary IP. But the router uses only one of the WAN links for data transfer.

Could you please help me in configuring the Cisco 2600 router so that it would be able to use the two WAN links.

Thank You

Tigist


Amit Singh Thu, 03/22/2007 - 23:49

Tigist,


Please paste your branch router configuration.We will check and let you know the problem. try the below mentioned thing:


If you want to use both the links try adding two default routes on your branch 2600 router.


ip route 0.0.0.0 0.0.0.0


ip route 0.0.0.0 0.0.0.0


HTH,


-amit singh

tigist_abe Fri, 03/23/2007 - 00:09

Amit singh,

I have pasted below the configuration of the branch router. Please note that the ISP has forced as to use RIP.



Building configuration...


Current configuration : 911 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname XXXXXX

!

boot-start-marker

boot-end-marker

!

enable secret

!


no network-clock-participate slot 1

no network-clock-participate wic 0

no aaa new-model

ip subnet-zero

ip cef

!

!

!

no ftp-server write-enable

!

!

!

!

interface FastEthernet0/0

ip address 172.31.12.221 255.255.255.0

ip helper-address 192.168.0.2

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 172.31.22.2 255.255.255.0 secondary

ip address 172.31.2.2 255.255.255.0

duplex auto

speed auto

!

router rip

version 2

network 172.31.0.0

!

ip classless

ip http server

!

!

line con 0

line aux 0


end



Tigist

Amit Singh Fri, 03/23/2007 - 00:19

Tigist,


As you are using RIP, so we have to make sure that we are learing the HO routes via both the routers and if the metric is same the RIP should do the load-balancing.


Please paste the "show ip route " from your router and also let us know the " Ip subnets " that you have in the Head office .


-amit singh

tigist_abe Fri, 03/23/2007 - 01:20

Amit singh,

both WAN links learn the different routes ( as posted below). But fro the head office network I cannot ping or access one of the WAN links (ADSL). Please note that the two WAN links are from the same ISP.

how can I check the load (data transfered) from the WAN links?


XXXXXX#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route


Gateway of last resort is not set


172.16.0.0/24 is subnetted, 1 subnets

R 172.16.1.0 [120/2] via 172.31.2.1, 00:00:05, FastEthernet0/1

[120/2] via 172.31.22.1, 00:00:12, FastEthernet0/1

172.31.0.0/24 is subnetted, 23 subnets

R 172.31.41.0 [120/2] via 172.31.2.1, 00:00:05, FastEthernet0/1

R 172.31.19.0 [120/2] via 172.31.2.1, 00:00:05, FastEthernet0/1

[120/2] via 172.31.22.1, 00:00:12, FastEthernet0/1

R 172.31.18.0 [120/2] via 172.31.22.1, 00:00:12, FastEthernet0/1

R 172.31.17.0 [120/2] via 172.31.2.1, 00:00:05, FastEthernet0/1

[120/2] via 172.31.22.1, 00:00:12, FastEthernet0/1

R 172.31.16.0 [120/2] via 172.31.22.1, 00:00:12, FastEthernet0/1

R 172.31.23.0 [120/2] via 172.31.2.1, 00:00:05, FastEthernet0/1

C 172.31.22.0 is directly connected, FastEthernet0/1

R 172.31.21.0 [120/2] via 172.31.2.1, 00:00:05, FastEthernet0/1

[120/2] via 172.31.22.1, 00:00:12, FastEthernet0/1

R 172.31.20.0 [120/2] via 172.31.22.1, 00:00:18, FastEthernet0/1

R 172.31.31.0 [120/2] via 172.31.2.1, 00:00:12, FastEthernet0/1

[120/2] via 172.31.22.1, 00:00:18, FastEthernet0/1

R 172.31.3.0 [120/2] via 172.31.22.1, 00:00:18, FastEthernet0/1

C 172.31.2.0 is directly connected, FastEthernet0/1

R 172.31.1.0 [120/2] via 172.31.2.1, 00:00:12, FastEthernet0/1

[120/2] via 172.31.22.1, 00:00:18, FastEthernet0/1

R 172.31.7.0 [120/2] via 172.31.2.1, 00:00:12, FastEthernet0/1

[120/2] via 172.31.22.1, 00:00:18, FastEthernet0/1

R 172.31.6.0 [120/2] via 172.31.22.1, 00:00:18, FastEthernet0/1

R 172.31.5.0 [120/2] via 172.31.22.1, 00:00:18, FastEthernet0/1

R 172.31.11.0 [120/2] via 172.31.2.1, 00:00:12, FastEthernet0/1

[120/2] via 172.31.22.1, 00:00:18, FastEthernet0/1

R 172.31.10.0 [120/3] via 172.31.2.1, 00:00:12, FastEthernet0/1

[120/3] via 172.31.22.1, 00:00:18, FastEthernet0/1

R 172.31.9.0 [120/2] via 172.31.2.1, 00:00:12, FastEthernet0/1

[120/2] via 172.31.22.1, 00:00:18, FastEthernet0/1

R 172.31.8.0 [120/2] via 172.31.22.1, 00:00:18, FastEthernet0/1

R 172.31.15.0 [120/2] via 172.31.22.1, 00:00:18, FastEthernet0/1

R 172.31.13.0 [120/2] via 172.31.22.1, 00:00:18, FastEthernet0/1

C 172.31.12.0 is directly connected, FastEthernet0/0

172.30.0.0/24 is subnetted, 1 subnets

R 172.30.6.0 [120/2] via 172.31.22.1, 00:00:18, FastEthernet0/1

thank you,

Tigist

norman_santana Fri, 03/30/2007 - 15:52

hello :


I agree with Amit singh


disable RIP and use the static routes


ip route 0.0.0.0 0.0.0.0 UBRXXX


ip route 0.0.0.0 0.0.0.0 ADSL 1


IF One link goes down the router will route the trafic by the link in service.



Another coments .. If you wanna have a HA schema why not acquire links with diferents ISP.



let me know if works.


Regards


Norman Santana

Actions

This Discussion