FAX on FXS troubleshooting help

Answered Question
Mar 22nd, 2007
User Badges:

I have problems with a new installation. CM 4.1 and mgcp controlled 2821 router with one e1 and 8fxs ports.

faxes on FXS port on the router fail. 1 page fax usually goes through, but any more than that and it will almost certainly fail half way through the page.

The router is running ver12.4(13)a IOS

I have reduced speed on fax to 14.4bps and turned off ECM but still doesn't work.I have read all the docs regarding mgcp setup for fax passthrough but cant see why this is failing. Anyone have any ideas, i attach my config and debug.


colin



Correct Answer by acampbell about 10 years 1 month ago

Hi Colin,


Can you check that you have set up network clocking for the router as this is what usually causes the poroblem of only one fax page being processed properly.


show network


This should show where the router is being clocked from, if you havent configured the clock at all you will be showing an internal router clock . Ideally you want to be clocking from the E1 link if it is connected to a ISDN/PSTN service provider. This peice of config is from a 3845 but it will be similar for you.


!

network-clock-participate wic 0

network-clock-select 1 E1 0/0

!


This sets the clock preference (1) to be the ISDN line


hope this helps


Alex.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
acampbell Thu, 03/22/2007 - 14:33
User Badges:
  • Green, 3000 points or more

Hi Colin,


Can you check that you have set up network clocking for the router as this is what usually causes the poroblem of only one fax page being processed properly.


show network


This should show where the router is being clocked from, if you havent configured the clock at all you will be showing an internal router clock . Ideally you want to be clocking from the E1 link if it is connected to a ISDN/PSTN service provider. This peice of config is from a 3845 but it will be similar for you.


!

network-clock-participate wic 0

network-clock-select 1 E1 0/0

!


This sets the clock preference (1) to be the ISDN line


hope this helps


Alex.


ReadersUK Fri, 03/23/2007 - 00:47
User Badges:

Hi Alex


I found a note on this late last night after i made this post, Our E1 controller was showing a lot of frame slips so i made the changes you sugggested. I am just waiting for someone in our finish office to come in and test.

ill let you know how we get on


regards Colin

dgahm Thu, 03/22/2007 - 15:50
User Badges:
  • Blue, 1500 points or more

Colin,

I fought the same battle, and ended up converting the fax FXS ports to H323, leaving the PRI set for MGCP. This has been a very solid setup for faxes.


Please rate helpful posts.


Dave

ReadersUK Fri, 03/23/2007 - 00:52
User Badges:

Hi Dave


Thanks for your reply, i am currently looking at the E1 to fix some frame slips. However if that doesnt work i might try h323. I did play with setting up h323 yesterday but couldt get an incoming call from the E1 to the fxs port or get the fxs to dial out. I thought it might be because the E1 is backhauled to the CallManager or more likely my dial peer was wrong. Do you have a copy of a working config? i would like to try and get an ATA186 working on the same router with h323.


Regards


Colin


Colin

ReadersUK Fri, 03/23/2007 - 03:11
User Badges:

After setting network clock to line on e1, our test faxes work fine.

sohaildxbfze Fri, 03/23/2007 - 10:23
User Badges:

Hi,

Try to upgrade your ios to

C2800NM-IPVOICE-M), Version 12.4(1a)

ReadersUK Fri, 03/23/2007 - 11:03
User Badges:

Hi Thanks for your reply, but problem has now been solved

colin

Actions

This Discussion