incomplete arp

Unanswered Question
Mar 23rd, 2007

I do have a 6500 and in RP im getting lot of Incomplete ARP entries for a particular ip block and keep on increasing and some time it's not there.

Even after clearing sevarla times the same status appears.

any suggetions would be helpful.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Richard Burts Fri, 03/23/2007 - 03:51


The incomplete ARP is caused when your RP sends an ARP request out and waits for a response. If it receives a response it then creates a complete entry in the ARP table. If it does not receive a response it keeps the incomplete entry for a short time (waiting to see if there will be a response) and then removes the incomplete entry. When you look and there are no incomplete entries it just means that there have not been recent requests for those addresses. When you do see incomplete entries it means that there have been recent requests for those addresses.

So the question becomes why is your RP sending ARP requests for these addresses? It probably means that some device (it could be an end station or could be another router connected to your RP) is sending you these packets and you are trying to forward them and need to ARP for the MAC address to forward to.

One thing that I have seen that sometimes causes these symptoms is a static route pointing to a LAN interface. Perhaps it is a default route like ip route FastEthernet0/0. Or perhaps it is a route for a network like ip route FastEthernet0/0. Do you have any static routes which point to outbound interfaces rather than identifying the next hop address?



dmitrysherman Fri, 03/23/2007 - 07:59

I agree with Rick, a route only to an interface may cause such thing.

Create a rotue to an interface and a next-hop together:

ip route fa0/0


Richard Burts Sat, 04/21/2007 - 10:59


I responded and suggested an idea. Perhaps you can tell us whether you have any static routes which point to an outbound interface.




This Discussion