RME devices not being backed up

Unanswered Question
Mar 23rd, 2007

I have installed Ciscoworks and i have a problem backing up devices in RME. the error message is :

Cause: CM0205 Device package for 145.55.1.133 not found Check whether the specified package path

- ""C:/PROGRA~1/CSCOpx/MDC/tomcat/webapps/rme/WEB-INF/lib/pkgs"" is correct Action:

Check if required device packages are available in RME. Action: Check if protocol is supported by device

and required device package is installed.

I have checked the file location that is listed and there is a number od the devices listed. However they are all ZIP files is that correct ?

I have also checked Common services/software centre/device updates :

And there is 466 device count for RME.

Not sure why I keep getting this message but if anyone can help that would be great.

cheers

Steve

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
David Stanford Fri, 03/23/2007 - 08:03

Is this message happening for all devices or just specific types? What version of RME are you running and did you recently install or upgrade?

Also, can you select a device and do a check device credentials to see if everything is ok? Can you also turn on debugs for achive mgmt to see if there are any other errors?

unilever01 Fri, 03/23/2007 - 08:34

yes the message is happing for all devices. The device credential are correct.

RME 4.0.5

How do I turn on debugs for achive mgmt ?

cheers

Steve

Joe Clarke Fri, 03/23/2007 - 15:53

Debugging is enabled under RME > Admin > System Preferences > Loglevel Settings. You need to enable ArchiveMgmt Service debugging. Then pick ONE failing device, and run a sync archive for that device. The resulting dcmaservice.log will have more details.

Typically this error points to a problem the RME package repository under NMSROOT/MDC/tomcat/webapps/rme/WEB-INF/lib/pkgs. If packages are missing from here, RME will not be able to operate on devices even though Common Services Software Center claims the device package is installed.

unilever01 Mon, 03/26/2007 - 01:37

I have attached the debegging file for two devices that I have checked 145.55.1.132 & 145.55.1.171.

One device is a 6509 cat & the other is a 2960.

When I check the devices in device centre both models are shown in the device type. If the devices are known in device centre how come they are not known in RME ?

Please can you check the attached file to see if it gives us any clues ?

cheers

Steve

Attachment: 
Joe Clarke Mon, 03/26/2007 - 09:55

This does look like you're missing the Cat6000 package. You should have two copies of the Cat6000.zip file. One is under NMSROOT/MDC/tomcat/webapps/rme/WEB-INF/lib/pkgs and the other is under NMSROOT/www/classpath/com/cisco/nm/xms/psu/pkgs/rme . They must be identical. If you do not have either, this points to a bad RME installation.

The same goes for the Cat2960 package. Where do these packages exist on your system? What version (if any) of each is reported under Common Services > Software Center > Device Update (click on the Resource Manager Essentials link)?

unilever01 Tue, 03/27/2007 - 00:55

In both of the directories above there is a copy of both of the files (Cat6000.zip & Cat2960.zip).

Cat2960 version 2.0

Cat6000 version 2.0

I have also tried removing the RME software and re-installing it. This is still not working.

Any suggestions ?

cheers

Steve

Joe Clarke Tue, 03/27/2007 - 10:34

What are the byte sizes of each of the files? What version of RME is this?

unilever01 Wed, 03/28/2007 - 03:05

The files are :

cat6000.zip = 17K

cat2960.zip = 12K

RME is version 4.0.5

cheers

Steve

Joe Clarke Wed, 03/28/2007 - 07:46

I meant byte size, not KB size. But if you have LMS 2.6, there is a newer version of the Cat2960 package on Cisco.com. You might try updating the available packages under Common Services > Software Center > Device Update, and see if the the 2960 problem goes away.

But please provide the byte size for BOTH Cat6000.zip files on the system.

unilever01 Wed, 03/28/2007 - 11:30

I have downloaded the new file and it makes no difference. I have got lms 2.6 installed.

The file sizes are :

Cat6000.zip = 16606 bytes

cat2960.zip = 12119 bytes

cheers

steve

Joe Clarke Wed, 03/28/2007 - 11:40

In which of the two locations on the server do you find files with these sizes? If both locations, then they are both corrupt. The actual size of Cat6000.zip for package version 2.0 should be 202164.

unilever01 Thu, 03/29/2007 - 00:44

It is in both lcations. Should I re-intsall the RME part again as it is corrupt ?

cheers

steve

Joe Clarke Thu, 03/29/2007 - 07:31

A simple reinstallation will not fix this. You will need to uninstall RME first, then set the TEMP and TMP environment variables to something short (i.e. C:\TEMP), then reinstall and re-patch RME.

unilever01 Fri, 03/30/2007 - 07:34

I have re-intsalled the software completly and all is working now. Many thanks for you help.

cheers

Steve

Actions

This Discussion