How to configure voice & data VLANs for a 3524?

Unanswered Question
Mar 23rd, 2007

What is the configuration for a 3524 and a 2610 in a small lab setup. There are two servers, a publisher and a subscriber connected to the switch via 0/1 and 0/2 respectively. There are three 7960s connected to ports 0/3, 0/4 and 0/5. The 2610 router (one ethernet interface) is connected to 0/6. How can I configure the ports and interface to support a voice and data VLAN? The phones all work and I can ping the router (all interfaces) from the pubblisher and subscriber. I can ping all of the devices from the router except the switch. Below is what I have, as far as configuration, but I can't ping the switch from the router and visa versa. And, I can't make outside calls (through the router to the PSTN via FXO). Any ideas on what I'm missing? Is this even the right forum for this? Thanks.

router

interface loopback 0

ip address 192.168.1.1 255.255.255.255

ethernet 0/0

no ip address

ethernet 0/0.1

description data VLAN

encapsulation dot1q 1 native

ip address 20.10.10.55 255.0.0.0

ethernet 0/0.2

description voice VLAN

encapsulation dot1q 172

ip address 10.10.10.55 255.0.0.0

router eigrp 1

network 10.0.0.0

network 20.0.0.0

no auto-summary

ip route 0.0.0.0 0.0.0.0 ethernet 0/0.1

Switch

FastEthernet 0/1

switchport access vlan 172

FastEthernet 0/2

switchport access vlan 172

FastEthernet 0/3

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan 172

FastEthernet 0/4

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan 172

FastEthernet 0/5

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan 172

FastEthernet 0/6

switchport trunk encapsulation dot1q

switchport mode trunk

interface VLAN 1

ip address 20.10.10.54 255.0.0.0

ip default-gateway 20.10.10.55

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 3 (1 ratings)
jgolia Sun, 03/25/2007 - 05:28

Anthony,

Is interface VLAN1 on your 3524 up/up? Perhaps it needs a "no shutdown".

Also for that interface on the switch to come up it may need an interface to be active in VL1, however your trunk on 0/6 should do it.

Also issue Show Interface Trunk on the 3524, and ensure that your native Vlan is matching what you have configured on your 2610.

Please rate helpful posts,

Jeff

d.anthony.hadley_2 Mon, 03/26/2007 - 07:22

hanks for the response. The interface VLAN 1 is up/up. I did a no shutdown on it, still no change. I did a show interface fast 0/6 switchport and it shows that the Native VLAN is 1 (active) and the interface is in vlan 1 and 172. Anything else that I might be missing, or that i can check? Thanks.

Actions

Login or Register to take actions

This Discussion

Posted March 23, 2007 at 8:45 AM
Stats:
Replies:2 Avg. Rating:3
Views:633 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 21,031
2 15,047
3 10,325
4 8,014
5 4,856
Rank Username Points
126
105
98
57
56