International translation pattern problem

Answered Question
Mar 24th, 2007
User Badges:

I have this scenario,

I want translate or forward an internal extension number to an international number

So when any extension dials that four digit number like ?2525?, callmanager translates that number

To 0114512312312? ,

Should I use translation pattern or something else?

I tried translation pattern, but when I dial extension It doesn?t work.

It works when I translate 2525 to 18182321? national number.

But with international it is not working.

Any help, would be appreciated.


Correct Answer by Brandon Buffin about 10 years 3 months ago

One option is to create a separate route pattern of 9.01144234234234234 to match the number that you are translating to explicitly. Otherwise, you will be waiting on the interdigit timeout for the call to complete. You could also create a 9.011!# route pattern which would allow you to press # after dialing an international number to terminate digit input. This is a good practice outside of this particular case. For this case, I would recommend the first option.


Brandon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Brandon Buffin Mon, 03/26/2007 - 12:22
User Badges:
  • Purple, 4500 points or more

Yes, a translation pattern will do the job. Do you have a route pattern in place that will match the international number that you are translating to?


Brandon

soheilkatal Mon, 03/26/2007 - 13:03
User Badges:

yes i have.

and i am able to call international directly from my phone, but when i use translation pattern with international number,

the only thing that i hear is dial tone,

and no diaing.

but if i use national number

it will work.


Brandon Buffin Mon, 03/26/2007 - 13:05
User Badges:
  • Purple, 4500 points or more

Can you post a screenshot of your translation pattern and route pattern?


Brandon

Correct Answer
Brandon Buffin Mon, 03/26/2007 - 13:42
User Badges:
  • Purple, 4500 points or more

One option is to create a separate route pattern of 9.01144234234234234 to match the number that you are translating to explicitly. Otherwise, you will be waiting on the interdigit timeout for the call to complete. You could also create a 9.011!# route pattern which would allow you to press # after dialing an international number to terminate digit input. This is a good practice outside of this particular case. For this case, I would recommend the first option.


Brandon

astinus Wed, 03/28/2007 - 07:47
User Badges:
  • Bronze, 100 points or more

Out of curiosity, you don't have something like forced auth codes on the telco side do you? I notice on your route pattern you're not sending the external phone number mask, any chance your telco is just returning dial-tone and waiting for you to enter an accounting code?


Just a thought.


Jim

b.zimmerman Thu, 10/18/2007 - 05:07
User Badges:

Did you ever get this working? I am having the exact same issue, and I have a route pattern specifically for the international number, but it still will not work. But, when I change the translation pattern to a national number, it will work.


Thanks,


Brent

paolo bevilacqua Thu, 10/18/2007 - 05:26
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi,


do debug isdn q931 on the gateway, and you will notice that if an type/plan of international is specified in setup, then the number must have no leading zeros and begin with the country code directly.

Instead the same number but with correct international call codes, will be successful.

b.zimmerman Thu, 10/18/2007 - 05:33
User Badges:

Thanks for the reply. I actually just got this working about 5 minuteas ago. Even though I had the exact route pattern, I didn't have a pound at the end of it and we had 9.011! in our route patterns so Call Manager was still waiting for the inter-digit timeout because of the 9.011! route pattern. We added 9.011!# and added a pound at the end of the translation pattern, and it is now working. By adding that, I could also remove the specific route pattern we had in place for the international number. But, thanks again for the reply.


Brent

Actions

This Discussion