H.323 gateway and FXO for inbound . . .

Answered Question
Mar 24th, 2007

Hi,

First, thanks to anyone who can help me resolve what seems to be, on the surface, a basic issue.

I have a CM/Unity implementation that uses a 2610 as an MGCP gateway. Because my MGCP gateway isn't able to provide caller ID, I'm working on getting H.323 working on the router. I've come across some documentation on configurations, but they seem to be only somewhat related to what I'm doing and I've had to resort to using some reasoning to figure out how to get this is going to work. No luck so far.

I need to figure out how H.323 should be configured to only route inbound calls to my call handler. Can anyone recommend a document that goes through this or please outline a basic method for doing this? Any help would be greatly appreciated (being without caller ID is killing me.)

-Shikamaru

I have this problem too.
0 votes
Correct Answer by jgolia about 9 years 10 months ago

Shikamaru,

I'm going to assume that your 2610 has FXO ports, and not a PRI. In that case the config is quite simple. In my solution your Call Handler is 3333. Your CallManager is 2.2.2.2. Configure the H323 gateway in CCM with the loopback address.

voice translation-rule 3333

rule 3 /.+/ /3333/

voice translation-profile CH3333

translate called 3333

int lo0

ip addr 1.1.1.1 255.0.0.0

h323-gate voip int

h323-gate voip bind srcaddr 1.1.1.1

gateway

dial-peer voice 1 pots

! This is your incoming POTS Dial-Peer The voice port is your FXO

incoming called-number .

direct-inward-dial

translation-profile incoming CH3333

port 1/0/0

dial-peer voice 2 voip

!This is your incoming VOIP Dial-Peer. Will need for outbound calls.

incoming called-number .

no vad

dtmf-relay h245-alphanumeric

codec g711ulaw

! ( What codec are you using from your CCM? If only one codec is used, put it here. If more than one is a possibility, use voice-class codec )

dial-peer voice 3333 voip

destination-pattern 3333

session target ipv4:2.2.2.2

no vad

dtmf-relay h245-alphanumeric

codec g711ulaw

dial-peer voice 9 pots

destination-pattern 9T

port 1/0/0

! This is an outbound dial-peer. May need further tuning to get outbound calls fully functional. This will need a 9 to be sent in front of every number to the gateway. The gateway will drop the 9 and send the rest to Telco.

Please Rate Helpful Posts.

Thanks,

Jeff

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Loading.
Correct Answer
jgolia Sun, 03/25/2007 - 05:03

Shikamaru,

I'm going to assume that your 2610 has FXO ports, and not a PRI. In that case the config is quite simple. In my solution your Call Handler is 3333. Your CallManager is 2.2.2.2. Configure the H323 gateway in CCM with the loopback address.

voice translation-rule 3333

rule 3 /.+/ /3333/

voice translation-profile CH3333

translate called 3333

int lo0

ip addr 1.1.1.1 255.0.0.0

h323-gate voip int

h323-gate voip bind srcaddr 1.1.1.1

gateway

dial-peer voice 1 pots

! This is your incoming POTS Dial-Peer The voice port is your FXO

incoming called-number .

direct-inward-dial

translation-profile incoming CH3333

port 1/0/0

dial-peer voice 2 voip

!This is your incoming VOIP Dial-Peer. Will need for outbound calls.

incoming called-number .

no vad

dtmf-relay h245-alphanumeric

codec g711ulaw

! ( What codec are you using from your CCM? If only one codec is used, put it here. If more than one is a possibility, use voice-class codec )

dial-peer voice 3333 voip

destination-pattern 3333

session target ipv4:2.2.2.2

no vad

dtmf-relay h245-alphanumeric

codec g711ulaw

dial-peer voice 9 pots

destination-pattern 9T

port 1/0/0

! This is an outbound dial-peer. May need further tuning to get outbound calls fully functional. This will need a 9 to be sent in front of every number to the gateway. The gateway will drop the 9 and send the rest to Telco.

Please Rate Helpful Posts.

Thanks,

Jeff

shikamarunara Sun, 03/25/2007 - 10:16

Jeff,

Thank you for replying. I'm still having some trouble, please help if you can. I neglected to mention, for simplicity, that my 1/0/0 port will be incoming (which is my FXO analog line), and my 1/0/1 port will be outgoing (another FXO line which is a connection to a consumer VOIP adapter. This worked fine under MGCP) In other words, one is incoming, one is outgoing.

I've applied your config given my particular set up (I think your config assumed that both voice ports were being used for incoming and outgoing.) When applied, an incoming call gets 1 ring, then a dial tone. Outgoing doesn't get routed.

Here is the config as I've adapted it;

!This IP address is the H.323 gateway's name in CallManager

int lo0

ip addr 4.4.4.4 255.255.255.0

h323-gate voip int

h323-gate voip bind srcaddr 4.4.4.4

gateway

!This is the inbound dial-peer coming in on 1/0/0

dial-peer voice 2600 voip

destination-pattern 2600

session target ipv4:192.168.15.7

no vad

dtmf-relay h245-alphanumeric

codec g711ulaw

!This is the outgoing dial-peer going out on 1/0/1

dial-peer voice 9 pots

destination-pattern 9T

port 1/0/1

This doesn't work and I'm sure I'm missing something glaringly obvious. Can you help shed some light?

-Shikamaru

jgolia Sun, 03/25/2007 - 13:38

Shikamaru,

For inbound calls, from PSTN to CCM.

In my original config, your default inbound dial-peer 0 is replaced with dial-peer 1. You need to include that in your config. The dial tone you hear is because dial-peer 1 does not exist. When it does, your call will be routed because of the direct-inward-dial statement. Of course you will also need the voice translation-rule and voice translation-profile statements at the top of my config to translate any DNIS to 3333.

For outbound calls, from CCM to PSTN.

Have you modified your route lists in CCM to send the 9 in front of every number, and not strip it (Like a PreDot)?

You should use the Inbound dial-peers 1 and 2 as written above. Otherwise you will match default dial-peer 0 and have less control over your network. You should use all 4 dial-peers & translation in above config.

Explains the need for inbound dial-peer matching

http://www.cisco.com/en/US/tech/tk652/tk90/technologies_tech_note09186a0080147524.shtml

Explains Dial-Peer 0 settings that are used by default, direct-inward-dial

http://www.cisco.com/en/US/tech/tk652/tk90/technologies_tech_note09186a008010fed1.shtml

To make port 1/0/1 your outgoing port you only need to change the port statement in dial-peer 9 to port 1/0/1. Then 1/0/0 will be incoming and 1/0/1 will be only outgoing.

Please rate helpful posts.

Jeff

jgolia Sun, 03/25/2007 - 13:51

Shikamaru,

one other command:

voice-port 1/0/0

connection plar 3333

shikamarunara Sun, 03/25/2007 - 14:18

Hi Jeff,

Okay, I'll focus on the first part, inbound calling.

The dial peers for the call legs are configured as follows;

voice translation-rule 2600

rule 3 /.+/ /2600/

voice translation-profile CH2600

translate called 2600

dial-peer voice 1 pots

translation-profile incoming CH2600

incoming called-number .

direct-inward-dial

port 1/0/0

!

dial-peer voice 2 voip

incoming called-number .

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

So, this is meant to forward any calls reaching 1/0/0 to my CH at 2600. I've also added the plar statement to the voiceport as you mentioned. This yields a busy signal with the following attachement from "debug voice ccapi inout";

I'm trying to figure out if this is possibly an issue with the H.323 trunk on my CM. Any thought?

-Shikamaru

Attachment: 
jgolia Mon, 03/26/2007 - 04:46

Shikamaru,

You now have both inbound dial-peers. Where is the outbound dialpeer? The first config had as an example:

dial-peer voice 3333 voip

destination-pattern 3333

session target ipv4:2.2.2.2

no vad

dtmf-relay h245-alphanumeric

codec g711ulaw

Based on further info (the number is 2600), you should configure

dial-peer voice 2600 voip

destination-pattern 2600

session target ipv4:2.2.2.2

no vad

dtmf-relay h245-alphanumeric

codec g711ulaw

To direct the call out of the router and into CCM. Your CCM IP Address is 2.2.2.2 in the above example.

The debug contains no mention of 2600.

HTH

Jeff

shikamarunara Mon, 03/26/2007 - 08:39

Jeff,

Thanks for your help, I have incoming calls routing properly now and I am working on the outbound (which I don't think should be a problem from this point on). Can you tell me how caller-id is typically enabled? I read in some cisco articles that enabling caller-id is done at the voice-port level, but I see no mention of the command when I hit "?".

-Shikamaru

shikamarunara Mon, 03/26/2007 - 13:08

I figured as much. There didn't seem to be any command syntax to enable it, so I saved my configs and moved everything back to MGCP :( Still, setting up dial peers was a good excercise that is necessary to know.

Oh, well. At least I can make and recieve calls perfectly (running unified Unity, too.)

-Shikamaru

Actions

This Discussion