Error in communicating with DCA Server in LMS 2.5.1

Unanswered Question
Mar 26th, 2007
User Badges:

Hi,i have problem with DCA serveur. When i attempt to open DCR i have that notification: Error in communicating with DCA Server.

DCA Server may be down. Please start the DCA Server and then refresh the page.

How can i start the DCA server ? i've tried to restart the server Ciscoworks with command line: net stop crmdmgtd and net start crmdmgtd. But problems persist.

help me please

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Martin Ermel Mon, 03/26/2007 - 05:49
User Badges:
  • Blue, 1500 points or more

check the DCRServer status with

pdshow DCRServer

what is the status? if it is down, try to restart it with

pdexec DCRServer


was the hostname of the server changed?


try to recreate the server certificate:

Server > Security > Single-Server Management > Certificate Setup

and restart the all daemons (net stop..)


is there any hint in dcr.log?


if this does not help, you should enable debug for dcr

diaration Wed, 03/28/2007 - 09:31
User Badges:

when i use the command pdshow DCRserver it indicate that process is never started et when i try to restart it i have that notification:

Error: get reply from server failed

Joe Clarke Wed, 03/28/2007 - 09:36
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

If the process is Never started, then one of its dependencies failed to properly initialize. DCRServer depends on TomcatMonitor, CmfDbMonitor, and EssMonitor. What are the states of those processes?

diaration Thu, 03/29/2007 - 10:30
User Badges:

CmfDbMonitor and EssMonitor are in running normally state but TomcatMonitor's state is : administrator has shut down this server. when I try to start it, it remains on this same state .help please!

Joe Clarke Thu, 03/29/2007 - 10:33
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Check your service startup parameters for the CiscoWorks services in the Service Control Panel. Please provide the complete list and their parameter.

diaration Thu, 03/29/2007 - 10:49
User Badges:

Services are:

ANIDbEngine:service started

CRMDmgtd:service started

RMEDbEngine:service started

Tomcat:service started

RmeOrb:service started

Apache:service started

CmfDbEngine:service started

crmrsh:service started

crmlog:service started

crmtftp:service started

EPMDbEngine:service started

FHDbEgine:service started

INVDbEngine:service started


Joe Clarke Thu, 03/29/2007 - 10:52
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

No, I want the startup parameter (i.e. Manual, Automatic).

diaration Mon, 04/02/2007 - 08:11
User Badges:

the startup parameter is automatic for all service except FHDbEngine and INVDbEngine their startup parameter is manual

Joe Clarke Mon, 04/02/2007 - 08:24
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

This is your problem. All services EXCEPT CiscoWorks Daemon Management, the CWCS services, and the IPM services MUST be set to Manual startup.


Here is a list of which services MUST be manual:


http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Network%20Infrastructure&topic=Network%20Management&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40%40.1ddc28c1/10#selected_message


After changing these parameters, reboot your server.

diaration Mon, 04/02/2007 - 09:46
User Badges:

I've changed these parameters but problems persist.

I think that the problem is due to the fact that I left the domain where it was at the time of the installation of LMS. Indeed I cannot reach any more the server by its name which is serverlms but by its address IP only.

http://serverlms:1741 don't work

http://192.168.10.10:1741 work for example but with error to DCA server

diaration Mon, 04/02/2007 - 10:24
User Badges:

Thanks you very very very much, my problem is solved.


Actions

This Discussion