isp dhcp failure on wan interface of 871

Unanswered Question

my 871 router will acquire a dhcp address from cox, and will work for awhile. After a seemingly random amount of time, I lose connectivity out the wan port. A release dhcp and renew dhcp at this point will fix the problem for another 'random' period of time. A linksys router has been working fine at this location for 2 years.




bringing same router into my work, it will not receive an ip address at all from our campus dhcp server. a computer hooked to this same port connects with no problems.


i also tried wiping out startup config, and only entering the following which yielded the same results:


ip address dhcp

no shutdown



i can statically assign an ip address to the wan interface, and everything works just fine.



as far as ios, i was initially using:

c870-advipservicesk9-mz.123-8.YI2.bin


then upgraded to the following which made no difference:

c870-advipservicesk9-mz.124-6.T.bin



i've been searching everywhere for a solution with nothing - and have asked cisco guys at work who tell me my config should work as is both at home and at work.


i'm thinking that i am either missing something simple, or i perhaps have a hardware problem.



Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

thank you very much for your response.


hard-coding speed/duplex does not seem to help.


with regard to the host name/client id. I called cox business support and they tell me that there is nothing out of the ordinary which I should need to do on my router to get it to work.


I would also like to note that with the existing linksys router, i plugged it in and it worked fine right out of the box.


here on our university network, I am certain that there are no such requirements in place - and it will not pull an ip address at all.

owaisberg Tue, 03/27/2007 - 09:31

Can you try run dhcp debugging:


# debug dhcp detail

# terminal monitor (if not on the console)


Please let me know if you see anything


Thx,

OW

owaisberg Tue, 03/27/2007 - 09:46

We want to make sure that debug runs all the time: when you get your IP first and then

when you loose it. Is it the case ?

Because I don't see you got any IP yet.


Thx,

OW

Right now I have the router hooked up at work, where dhcp will not work at all.


If it will help I can take it home with me again tonight to reproduce the output, however I did run it once before at home and there were no dhcp messages around the time when I lost connectivity. The only message I received after losing connectivity was when I performed the release dhcp / renew dhcp operation.


thank you.

owaisberg Tue, 03/27/2007 - 10:10

Please test it home then. As well, along

with DHCP debuging add "debug ip routing"


Ideally what we want to find is an indication

on when the IP address is withdrown from the

interface.


Please let me know.


HTH,

OW

owaisberg Tue, 03/27/2007 - 11:25

I understand, along with debug I want you to try to deactivate DHCP server you use

locally for your LAN (hope no problem with that as it is going to be your home network)

just to make sure there is no conflict between

DHCP client and server portion of your config.

As well, remove NAT and all other settings from that interface to make sure nothing is on it but DHCP client only.


Thx,

OW

ok. I tried as you said, first with nat, etc. still enabled. It behaved as it did before with no useful data (at least that i can tell - please see attached). Nothing came up at the time I lost connectivity which was somewhere between 07:36 and 07:37


I then completely erased config file, and only entered in commands to enable dhcp client on wan. I pinged the gateway for quite a long time and could not get anything to fail. the only debug info that I saw was the occasional message:

DHCP: Received a BOOTREP pkt Not for us..: xid: 0xE71BE83



in addition, my other router - an 871 (which you are probably aware is the exact same thing minus wireless) - showed up in the mail today. So I copied the same config/ios over to it and could not get it to fail at all using all the same cables.



owaisberg Tue, 03/27/2007 - 23:18

Do you mean that you copied full config to a new router and it works ? Or you had limited

config on it just to get connected.

Regardless of a new router it is obvious that

there is some "collision" with one of the features you run. If you remove NAT only and

leave the rest is it running okay ?

Sorry for the confusion. These are the tests I have performed last night and this morning:


1: router #1 - same config/ios as original test with same results. debug dhcp & ip routing output attached in previous message.


2: load that same config/ios on router #2 and was unable to get it to fail after 15 minutes.


3: delete config file from router #1, and only add the following lines:


ip address dhcp client-id FastEthernet4

no shutdown


Running for 10 minutes without a problem.


4: neither router will acquire a dynamic address from our campus network with basic config file containing only:


ip address dhcp client-id FastEthernet4

no shutdown


ios: c870-advipservicesk9-mz.124-6.T6.bin


5: Co-worker has an 806 which will pull an ip address on campus with no problem using same commands. He is going to (hopefully) bring it to me tomorrow so that I can verify this.

owaisberg Thu, 03/29/2007 - 06:38

Glad it end up as quick hardware replacement.


Thanks,

OW


* Please rate any useful posts

Hopefully a replacement will fix that problem.


However I am still confused about one other thing - if you are willing to help me troubleshoot that would be great -- otherwise I will move on.




neither one of my 871's will acquire an ip address from my work lan, or my linksys router at home.


But I hook up a cisco 806 running c806-k9osy6-mz.123-22 and it will acquire an ip address everytime, with no problems.



what I did for 871 & 871w


1: erase start

2: int fa4

3: ip address dhcp

(also tried ip address dhcp client-id FastEthernet4)

4: no shut


for the 806:


1: erase start

2: --806 was configured by default with below settings for Ethernet1:


ip address dhcp

owaisberg Thu, 03/29/2007 - 10:42

I was under the impression that you can acquire IP address but loose connectivity

in while after that.

Now, if connecting to the same LAN one router

is capable to acquire address and another one not using the same config then we are talking

of a differences in DHCP client functionality.

I understand that debugging DHCP didn't

produce any results but I find it strange as

I understood that at home you could get an IP

so we should have see DHCP process in debug

outputs.


Please confirm.


Thx,

OW

sorry for the late reply I have been out of town for a few days.


At home connected to a Cox Business line, both of my 871 routers would receive an IP address, but one of them would lose connectivity after a random period of time (even though a show ip route still showed the route as good).


At work connected to our campus network, neither one of the 871's will receive an IP address whereas an 806 will work with no problem.


Hooked into a cheapo linksys router yields the same results which I see at work (neither router will acquire an ip address).

Actions

This Discussion