subinterfaces - should i be able to ping them?

Unanswered Question
Mar 26th, 2007

silly question, should i be able to ping a subinterface?

i have the following config:

1841#sh run

Building configuration...

Current configuration : 1287 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname 1841

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

--More--

!

!

no ip dhcp use vrf connected

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.2

encapsulation dot1Q 2

ip address 10.1.21.1 255.255.255.224

no snmp trap link-status

!

interface FastEthernet0/0.3

encapsulation dot1Q 3

ip address 10.1.21.33 255.255.255.224

no snmp trap link-status

--More--

!

interface FastEthernet0/0.4

encapsulation dot1Q 4

ip address 10.1.21.65 255.255.255.224

no snmp trap link-status

!

interface FastEthernet0/0.5

encapsulation dot1Q 5

ip address 10.1.21.129 255.255.255.224

no snmp trap link-status

!

interface FastEthernet0/0.6

encapsulation dot1Q 6

ip address 10.1.21.193 255.255.255.224

no snmp trap link-status

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

--More--

no ip address

shutdown

clockrate 2000000

!

ip classless

!

ip http server

!

!

control-plane

line con 0

logging synchronous

line aux 0

line vty 0 4

login

!

end

i have a laptop plugged into the same switch as the router, with ip address of:

10.1.21.2 255.255.255.224

gateway 10.1.21.1

and i cant ping the subinterface 10.1.21.1

even from the router i cant ping the laptop 10.1.21.2...

this seems to simple its embarrassing... can anyone help?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ahmadabuzayyad Mon, 03/26/2007 - 22:05

based on the configuration that you write down, your laptop was inserted in vlan 2, so check the port that you insert the laptop if it is in the same vlan or the default.

the next things, most operating system with firewall feature deny icmp to pass the devices so may be your configuration is right, so try ping from switch to router or from subinterface to the other sub interface.

LucaSalvatore_2 Mon, 03/26/2007 - 22:17

yes the router and the laptop are in the same VLAN which is vlan2.

its a windows xp laptop with the firewall disabled.

i can ping all subinterfaces from the router,

i should elaborate... im trying to setup some VLANs in a test lab, i cannot get devices on different VLANs to communicate, devices in the same vlan communicate fine but not different VLANs.

This obviously is a router problem since communication between vlans requires a layer 3 device... but as far as i can see my config on the router is good.

ahmadabuzayyad Mon, 03/26/2007 - 22:31

even if you disable firewall you must spesifically permt icmp echo from windows

by the way your switch muxt 2950 or up at least since 1900 series just support isl and not dot1q.

for finishing the test create

interface vlan 2

ip address

and try to ping it from the switch and if it is okay so there is no error and just matter of icmp port issue.

otherwise we will think about it

rate if it is helpfull

LucaSalvatore_2 Mon, 03/26/2007 - 22:45

im pretty sure this is not the problem as ping traffic works fine for devices in the same vlan.

if I get rid of my subinterfaces and set an ip address on the physical interface i can ping it without an issue.

note im using a dell 2724 switch (dont yell! haha)

cpembleton Mon, 03/26/2007 - 22:08

Is the switch port the router is connected to setup for trunking with do1q encap? Is your client in the correct VLan?

Thanks,

Chad

mahmoodmkl Mon, 03/26/2007 - 22:30

HI

Can u verify the port on ur switch is trunking and all the vlans are allowed on it.

Thanks

Mahmood

Actions

This Discussion