PPPOE dialing

Unanswered Question
Mar 26th, 2007

Why my pppoe connection always disconect?

bellow is my config and debug :




ip sla monitor 1

type dns target-addr http://www.google.com name-server 202.188.0.133

timeout 2000

threshold 4

frequency 15

ip sla monitor schedule 1 life forever start-time now

vpdn enable

!

!

isdn switch-type basic-net3

!

!

!

!

!

track 1 rtr 1 reachability

!

!

crypto isakmp policy 10

hash md5

authentication pre-share

group 2

lifetime 43200

crypto isakmp key xxx address 58.x.x.99

crypto isakmp key xxx address 218.x.x.146

crypto isakmp invalid-spi-recovery

crypto isakmp keepalive 15 15 periodic

!

!

crypto ipsec transform-set CMSET esp-3des esp-md5-hmac

crypto ipsec df-bit clear

!

crypto map CMMAP 10 ipsec-isakmp

set peer 58.26.35.99

set peer 218.208.36.146

set transform-set CMSET

match address 110

!

!

!

interface Loopback0

ip address 219.93.x.x.255.255.255

crypto map CMMAP

!

interface BRI0

description $BACKUP_INTF_Ethernet0_TRACK_1$

no ip address

encapsulation ppp

dialer rotary-group 0

dialer-group 1

isdn switch-type basic-net3

isdn point-to-point-setup

crypto map CMMAP

!

interface Ethernet0

description ***PPPOE***

bandwidth 1024

no ip address

ip tcp adjust-mss 1452

shutdown

half-duplex

pppoe enable

pppoe-client dial-pool-number 1

!

interface FastEthernet0

ip address 10.106.163.1 255.255.255.0

speed auto

!

interface Dialer0

ip address negotiated

encapsulation ppp

dialer in-band

dialer idle-timeout 500 either

dialer string 1525

dialer hold-queue 10

dialer load-threshold 1 either

dialer-group 1

ppp pap sent-username icourtsn@fixed password xxx

ppp multilink

crypto map CMMAP

!

interface Dialer1

description *** For ADSL Dialup ***

ip address negotiated

encapsulation ppp

dialer pool 1

dialer idle-timeout 14400 either

dialer-group 1

ppp authentication pap callin

ppp pap sent-username courtsrn@streamyx password 0 tmnet123

crypto map CMMAP

!

ip local policy route-map SDM_BACKUP_RMAP_1

ip route 0.0.0.0 0.0.0.0 Dialer1 track 1

ip route 0.0.0.0 0.0.0.0 Dialer0 200

ip route 202.x.x.133 255.255.255.255 Dialer1

!

no ip http server

no ip http secure-server

ip nat inside source route-map SDM_RMAP_1 interface Dialer1 overload

!

access-list 10 remark *** To disable IPS for VPN traffic ***

access-list 10 deny 10.106.0.0 0.0.7.255

access-list 10 deny 100.1.1.0 0.0.0.255

access-list 10 permit any

access-list 100 permit ip any host 202.188.1.5

access-list 100 permit ip any host 202.188.0.133

access-list 110 permit ip 10.106.163.0 0.0.0.255 10.106.0.0 0.0.7.255

access-list 110 permit ip 10.106.163.0 0.0.0.255 100.1.1.0 0.0.0.255

access-list 120 remark *** To disable NAT for VPN traffic ***

access-list 120 deny ip 10.106.163.0 0.0.0.255 10.106.0.0 0.0.7.255

access-list 120 deny ip 10.106.163.0 0.0.0.255 100.1.1.0 0.0.0.255

access-list 120 permit ip 10.106.163.0 0.0.0.255 any

dialer-list 1 protocol ip permit

snmp-server community CMSNMP RO

snmp-server enable traps tty

route-map SDM_BACKUP_RMAP_1 permit 1

match ip address 100

set interface Dialer1

!

route-map SDM_RMAP_1 permit 1

match ip address 120

!

!

control-plane

!

!

line con 0

login

line aux 0

line vty 0 4

exec-timeout 600 0

logging synchronous

login

!

ntp clock-period 17179941

ntp server 192.228.128.20 prefer

end



debug pppoe event:


Mar 27 13:28:37: PPPoE : Shutting down client session

Mar 27 13:28:37: [0]PPPoE 566: O PADT R:0090.1aa0.6100 L:0004.dc0d.c11f Et0

Mar 27 13:28:37: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di1

Mar 27 13:28:37: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down

Mar 27 13:28:38: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to down



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
owaisberg Tue, 03/27/2007 - 21:50

Please run "debug ppp authentication"

and "debug ppp negotiation" and redirect

that to syslog server (in case your disconnect is intermittent). If you see

no authentication failures when disconnected,

then try to run PPPoE config only to make sure there is no collision with other features you're running.


HTH,

OW

Actions

This Discussion