please help in FXO Disconnection problem

Unanswered Question
Mar 27th, 2007

hi all,

i have a callmanager 4.2 and cisco 2811 as avoice gateway (MGCP)with 2 vic2-4fxo ports,

the problem appeares when some one from outside places a call into the system the line keeps ringing even when the calling party goes on hock,

although i solved this problem previously on 1760 gateway with the following commands under the voice ports;

voice-port 1/0

supervisory disconnect dualtone mid-call

cptone EG

timeouts call-disconnect 0

timeouts wait-release 1

timing hookflash-out 500

connection plar opx 0

these commands have no effect in my case

another very starnge thing happens that the command "cptone EG" disappears from the cofiguration after some time or after a reload (although i make copy run start).

so please can any one helps me to fix this issue

thanks in advance

Eng. Ahmed Abd EL-Rahman


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
a.gooding Tue, 03/27/2007 - 18:56


along with your commands i also had to ask the carrier to enalbe COD on thier end. to do that, they had to put the pstn lines in a trunk and then enable COD. that worked. other than that, some say ground start works but not everytime.

J_Vansen_S Tue, 03/27/2007 - 23:20

Try using a custome tone to disconnect the call. This works fine for me, as i was facing the same problem as urs previously.

One thing u gotta get the frequency right according to your PBX or country dial tone frequency n cadence.


voice class custom-cptone test

dualtone busy

frequency 400 400

cadence 375 375

dualtone disconnect

frequency 400 400

cadence 375 375


voice-port 0/0/0

supervisory disconnect dualtone mid-call

supervisory custom-cptone test


When Ground start and battery reversal does not help in solving this issue. So we are down to using tone supervisory to disconnect the call.

osamaokok Sun, 04/01/2007 - 09:14


I'm facing the same problem, i did what all guys said but no luck.

So please if you get the answer please post it.


ahmed-hassan1110 Sun, 04/01/2007 - 10:19

i'm still didn't solve the problem.

but i notice that the command "cptone EG" which i make under the voice ports is reseted to cptone US after reloading although i make copy run start

so please what could be the reason for this?

ahmed-hassan1110 Sun, 04/01/2007 - 15:31

i think that i have the latest IOS and hereby the result of sh version command on the voice gateway

"Cisco IOS Software, 2800 Software (C2800NM-SPSERVICESK9-M), Version 12.4(3f), RE


so am i still need to upgrade the IOS ?


This Discussion