1473 byte ping drops

Unanswered Question
Mar 28th, 2007

Hi,

I can ping a particular router say site X with 1500 byte packets pretty well from all of our wan sites however when I ping the same router from a pc or a lan device from the same wan sites the 1500 pings dont go through, 1472 pings go through but from 1473 onwards they fail. trying ping x.x.x.x -f -t -l 1473 gives me the following message : Packet needs to be fragmented but DF set.

Would it be an mtu issue within the retail carrier cloud or our router at site X? Some sort of mtu negotiation is failing maybe from a partcular device to our pc but which device? Plus why do router to router pings of 1500 bytes work and as mentioned above from pc to the same router it fails? If someone has come across this can you please advise.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
ankbhasi Wed, 03/28/2007 - 02:56

Hi Friend,

When you are trying to ping from pc you are setting a Don't Fragment bit which will not fragment the packet and will be dropped.

ping x.x.x.x -f -t -l 1473

Do not use the option -f

just try ping x.x.x.x -t -l 1500 and see if works for you.

HTH

Ankur

*Pls rate all helpfull post

VPMaharaj Wed, 03/28/2007 - 03:03

thanks Ankur but that is what the problem is. My 1500 byte pings still fail even without -f. I had done the -f bit for troubleshooting purposes.

Amit Singh Wed, 03/28/2007 - 03:37

What is the topology that we have in here. I think there is some routing device in the middle which doesnot support the MTU size over 1472. This could be the problem with the NIC card itself.

Switches do not support fragmentation so it has to be either a L3 device or the NIC cards itself.I have come across some of the NIC cards which do not support 1500 MTU size. Make sure that all the intermediate devices have proper MTU on the interfaces and if its there then the problem will be with the NIC card itself.

Please check the link below and it should help.

http://www.cisco.com/en/US/tech/tk870/tk877/tk880/technologies_tech_note09186a008011a218.shtml

HTH,

-amit singh

VPMaharaj Wed, 03/28/2007 - 03:46

thanks Amit. 1500 pings from the same pc works ok to the other sites however only site X fails so it probably is not a pc issue. However pinging from the routers and switches from all these site to the site X router and 1500 pings are fine.

Amit Singh Wed, 03/28/2007 - 04:24

You have mentioned that ping from router and switches from different sites to router X works OK.What happens when you ping from a host located in different sites to the site X router.

Do you see the same behaviour?

-amit singh

VPMaharaj Wed, 03/28/2007 - 05:56

Thanks Amit. I got the same result from the other sites. I also found out that it seems to work from 1560 bytes onwards - funny! I have reloaded the router but to no success. (Also the symptoms are in both directions.) Hence it seems packet sizes from 1473 bytes to around 1550 bytes (roughly) have problems and the rest work!

Actions

This Discussion