Dual Wan Dual Lan

Unanswered Question

I have 2 companies that have been sharing a ADSL connection but have now outgrown it's bandwith, so we've added a T1 and kept the DSL line as well(although it's not in use right now, till I can get it working). Each company has it's own LAN and I want to configure Each LAN to use a it's own WAN route. Company A will use the T1 and Company B the ADSL.



Company A LAN 192.168.3.0 255.255.255.0

Company B LAN 192.168.4.0 255.255.255.0


Router: Cisco 2811 with 2 FE with a HWIC 4port switch divided into VLANs with the above subnets.The IOS on the router is 2800 Software (C2800NM-ADVSECURITYK9-M), Version 12.4(6)T2


Would I use Routemaps to accomplish this task? or will I need something like PBR?


Please provide an example.



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
paolo bevilacqua Wed, 03/28/2007 - 16:00
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Sure you can do that. The T1 provider and the ADSL one gives you separate addresses on which you will configure nat/pat. With routemaps this alone should ensure the packet is going out the right interface.

See:

http://cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a008044eddc.html#wp1073518


So no PBR should be necessary.


Things gets interesting when you want to configure mutual backup for both wan links ...


Hope this helps, if so please rate post !

I looked at the link you provided but I can't see how to setup the routemap, I see lots of documentation on how to do such things with BGP,RIP, etc the dynamic routing protocols but I only have static routes as options to me. The only way I see to set this thing up seems to use some PBR commands, below is what I think might work? Suggestions?

----------------------------------------

*** Assume this ***

Company A T1 -> 192.168.3.0 (LAN)

Company B ADSL -> 192.168.4.0 (LAN)

----------------------------------------





access-list 10 permit 192.168.3.0 255.255.255.0


access-list 20 permit 192.168.4.0 255.255.255.0



route-map t1_Access permit 100

match ip addess 10

set next-hop



route-map adsl_Access permit 200

match ip addess 20

set next-hop

paolo bevilacqua Thu, 04/05/2007 - 12:24
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member


Hi, I think you will need two nat commands:

ip nat inside source route-map t1_Access interface Serial0/0 overload

ip nat inside source route-map adsl_Access interface ATM0/1.1 overload


route-map t1_Access permit 100

match ip addess 10

set interface S0/0



route-map adsl_Access permit 200

match ip addess 20

set interface ATM1/0.1


This way you do not even need to know gateway addresses.







ilya.varlashkin Thu, 04/05/2007 - 12:58
User Badges:
  • Silver, 250 points or more



If those are only your requirements, you could also create on your 2800 router four vrf - one for each, assign each interface into its own VRF and set import export policies so that WAN1 VRF imports only LAN1 prefixes, while LAN1 imports both WAN1 and LAN2 prefixes and so on. This way no messy setups with policy routing.

Actions

This Discussion