using an AP aironet 1240ag to use a cisco 7920 to connect to callmanager?

Unanswered Question
Mar 29th, 2007

The situation is the following we are trying to install a cisco 7920 phone using an AP aironet 1240ag while connected to a switch that uses 2 vlans.

When we plug the AP into the switch the DHCP server assigns a 192.168.10.XXX IP address which is the data vlan. We need to use the voice vlan in order to registered the 7920 with callmanager.

So we went into the ap and set the IP statically to 10.0.0.XXX, 255.255.255.0 and still not able to appear in the switch still picking up the 192.168.10.XXX ip address. Which causes the cisco 7920 to pull 192.168.10.XXX.

We have tried to set the phone statiscally as well but is unable to reach call manager because the ap is unable to show in our system.

any help will be certanly appreciated thank you

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Paolo Bevilacqua Thu, 03/29/2007 - 06:11

Hi Charlotte,

the AP should use a static address in the management VLAN, that can be separated from data, but is certainly seprated from voice vlan. The AP needs to connect to a trunk port on the switch, and have the vlan / ssid mapping correctly configured. The phone will try to connect to the voice ssid/vlan, so that will get an address from the voice pool, that is how is supposed to work.

charlotterob Thu, 03/29/2007 - 06:49

I did set up the AP with an static IP address for example 10.0.0.250 and what is weird is that event though the ap is set up with an static ip address i cant use a pc within the 10.0.0.XXX network to connect to the AP, instead i have to use either the console or connect the AP directly to a hub and from the hud to a pc to access the web configuration pc of the AP?

charlotterob Thu, 03/29/2007 - 06:52

When you mean trunk port on the switch what do you mean?..This is 3 layer router 2811, isnt suppost to connect to the desire vlan as configured in the ap?..I have even set up the port where the ap is connected to only be the VLAN 10.0.0.XXX and still pulling the other VLAN by default 192.168.10.XXX ?

Paolo Bevilacqua Thu, 03/29/2007 - 07:00

Hi charlotte,

the thing is that unless you want to NOT have a ssid/vlan for data, the AP should have two ssid/vlans, hence the requirement for trunk port. I know that until you get the twist with professional networking all this seems to not make sense.

Now: are you connecting the AP directly to the embedded FA ports in the router? Or to a different module? Or there is a switch in between? Do you plan to use the TFTP server of CM?

charlotterob Thu, 03/29/2007 - 07:06

Well the you can configure the AP to use multiple vlans to be used with multiple SSID's.

The AP is connected directly to port 9 on the catalyst cisco switch.

Paolo Bevilacqua Thu, 03/29/2007 - 07:16

Right. Now configure port 9 on the switch for trunk mode - do you know how to do that ?

Also configure the switch port that goes to the router for trunk mode.

The router should have an interface into each VLAN/subnet.

int fa0/1.4

encapsulation dot1q 4

ip address 10.10.0.1 255.255.255.0

Be ready with a console cable to connect byserial into the devices because you can easily loose connectivity to the device you are configuring.

If you are not running DHCP on the router, in the VLAN interface also configure helper address to the DHCP address of the server that is supposed to give addresses to the phones.

But, doing all these things requires study / skills, at the end aren't you guys getting installation and support from who sold you the cisco gear ?

For most of the people here is no problem guiding you around, but it may take a very long time to get all things sorted out.

charlotterob Thu, 03/29/2007 - 07:32

This is what i got from the switch specially from port 9

interface FastEthernet0/9

description VOICE & DATA

switchport mode access

switchport voice vlan 1

switchport priority extend cos 0

no ip address

mls qos trust device cisco-phone

mls qos trust cos

storm-control broadcast level 50.00

storm-control multicast level 75.00

storm-control unicast level 75.00

auto qos voip cisco-phone

wrr-queue bandwidth 20 1 80 0

wrr-queue min-reserve 1 5

wrr-queue min-reserve 2 6

wrr-queue min-reserve 3 7

wrr-queue min-reserve 4 8

wrr-queue cos-map 1 0 1 2 4

wrr-queue cos-map 3 3 6 7

wrr-queue cos-map 4 5

priority-queue out

spanning-tree portfast

Paolo Bevilacqua Thu, 03/29/2007 - 07:45

Hi, the port is access mode and voice vlan set to 1 that should not be case, both ports to AP and router should be trunk for a professional installation. I hope this is not opening a can of worms but you may want to review the whole installation.

This may be a lot more complicated than yesterday's case where just the number of digits had to be guessed.

So unless you are redy to read a lot of configuration guides and manual, seek certified help now.

charlotterob Thu, 03/29/2007 - 07:57

right well whoever configured this thing was suppost to be

VLAN0 for data and VLAN1 for voice, but they didnt do it.

so how can i change the port 9 to be in a trunk mode? is that why the ap auto configure itself to use the other vlan?

Paolo Bevilacqua Thu, 03/29/2007 - 08:07

There is no vlan0. You could have vlan1 for data/management and that is the default vlan, then a separate vlan for voice.

For trunk, configure with "switchport mode trunk", but at this point it appears the whole system has no separate vlans, and you will have trouble insisting to separate ssid/vlans on the AP. Result, the phone will always pick address from the wrong pool.

Either you schedule downtime to reconfigure everything correctly, or find your way around to get the 7920 phone register to CCM despite the wrong address. I do not recommend you go this way because it may be also time consuming and efforts wasted to the wrong direction.

Sorry can't be of more help in this case.

charlotterob Thu, 03/29/2007 - 08:20

its does have different vlans

take a look port 5

interface FastEthernet0/5

description VOICE & DATA

switchport access vlan 2

switchport mode access

switchport voice vlan 1

switchport priority extend cos 0

no ip address

mls qos trust device cisco-phone

mls qos trust cos

storm-control broadcast level 50.00

storm-control multicast level 75.00

storm-control unicast level 75.00

auto qos voip cisco-phone

wrr-queue bandwidth 20 1 80 0

wrr-queue min-reserve 1 5

wrr-queue min-reserve 2 6

wrr-queue min-reserve 3 7

wrr-queue min-reserve 4 8

wrr-queue cos-map 1 0 1 2 4

wrr-queue cos-map 3 3 6 7

wrr-queue cos-map 4 5

priority-queue out

spanning-tree portfast

Well i have try to do set up 2 different vlans in the AP and of course with 2 different SSID's and the cisco 7920 with a set profile to pick up only the SSID that supposely will be using the voice vlan, and still not pulling the correct IP, still pulling the wrong ip address even though i am setting 2 different vlans on the AP.

thank you again for your time and patiences

Paolo Bevilacqua Thu, 03/29/2007 - 09:28

Set port 9 to trunk. Voice appears to be vlan 1 and data vlan2. Configure ap this way. The phone appears ending to be on the wrong vlan. Check that DHCP server has a pool for voice when requests are coming from the router interface to vlan1.

charlotterob Thu, 03/29/2007 - 12:02

You are entirely right, vlan1 is voice is vlan2 is data. the DHCP does have a pool for voice,

How do i go by setting the port 9 into trunk mode, also if i make this change would cause any problems with normal call processing?

Thank you again for your help, hey if you ever need help with Asterisk you can count with me 24/7 i took my ccna back in 99, and right now i am trying to refresh my head with commands,etc. I have started to read my cisco books again and i doing it daily almost 6 hours a day so i can get back to NORMAL, specially now that i need this information

since the position that i was moved into requieres a lot cisco info.

Thank you again for your help

Paolo Bevilacqua Thu, 03/29/2007 - 12:59

Ah, you if have networking background you can make it. Yes you can disrupt current working, so make a map of all the vlans, address and interfaces. Check and plan to that CM is into voice vlan, phones as well, etc.

Now, I think that CCM does not require that it is dhcp server for phones. So if you don't want to touch the DHCP server you can have the router be dhcp server. Create a dhcp pool that give address good for voice vlan. Put option 66 and 150 as CM address where the phone will register. Make sure router has interface into both voice and data vlan. The phone should get correct address and register.

charlotterob Thu, 03/29/2007 - 14:03

The CM is working on the vlan 1 voice, phones etc. you are right cm doesnt require dhcp server for phones, you can assign them manually, and thats what i did but doesnt do anything.

I dont know if this have something to do with it but.

Prior to our upgrade last year, you could plug up a phone, add it to the CM, and it would be fine. Now, I have to plug up a phone, turn off DHCP, manually enter the tftp server, gateway, and an unused IP address. Then, after the phone reboots, I can change it back to DHCP and configure it in the CM

So taking in consideration this i did the same in the cisco 7920. set up a profile statically, i mean the phone is able to communicate with ap using the ssid, but the ap is sending a different ip info to the phone and the phone have my configurations ,so it causes the cisco 7920 not to function correctly

Paolo Bevilacqua Thu, 03/29/2007 - 14:40

So basically the "upgrade" last year messed up the separation between data and voice vlan and you are left with the bad practice of having to do certain maneuvers including very unpractical static addressing.

As I said before it's quite possible that you can find a way to hack around things and make the 7920 work, but in my opinion it is more important to overhaul the whole install and make things work the way they are supposed, it is not very difficult anyway as you have all the right equipment apparently.

charlotterob Thu, 03/29/2007 - 15:07

but i was just looking at the issue with the phones not registering properly so i went to check one of the phone that we have recently installed and this is what i got?

CM Reject: Max Phones Exceeded

2006-12-12 18:36:22.102 Code:8105, P:0, S:12300804

2007-02-28 22:52:38.510 Code:8108, P:0, S:12300800

So with this info i went to check the ephone config on the 2811 and this is what i have?

call-manager-fallback

secondary-dialtone 9

max-conferences 8

limit-dn 7940 2

limit-dn 7960 6

timeouts interdigit 5

timeouts ringing 20

ip source-address 10.0.0.20 port 2000

max-ephones 42

max-dn 144

keepalive 10

default-destination 0100

no huntstop

call-forward pattern .T

call-forward busy 0100

call-forward noan 0100 timeout 20

moh music-on-hold.au

time-zone 12

!

as you can see

max-ephones 42 and we have more than 65 ip phones in our office.

This could be causing the auto registration issue and possibly causing the problem with ap as well what do you think?

can I set the max-ephones to lets say 90 ? if so I am pretty sure if i change this settings i am going to have to reboot the router in order to the settings to take effect and could this change affect the original configuration or it will only set the max-ephones to 90 and continue working as ussual?

I have try use the IPSU on a pc that is on vlan1 voice to find the AP and IPSU cant find the AP? weird.

thank you very much for your time

charlotterob Thu, 03/29/2007 - 18:52

alright i was able to trunk the port 0/9

!

interface FastEthernet0/9

description VOICE & DATA

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan 1

switchport priority extend cos 0

no ip address

mls qos trust device cisco-phone

mls qos trust cos

storm-control broadcast level 50.00

storm-control multicast level 75.00

storm-control unicast level 75.00

auto qos voip cisco-phone

wrr-queue bandwidth 20 1 80 0

wrr-queue min-reserve 1 5

wrr-queue min-reserve 2 6

wrr-queue min-reserve 3 7

wrr-queue min-reserve 4 8

wrr-queue cos-map 1 0 1 2 4

wrr-queue cos-map 3 3 6 7

wrr-queue cos-map 4 5

priority-queue out

spanning-tree portfast

!

same issue? what i do next?

Paolo Bevilacqua Fri, 03/30/2007 - 04:58

Hi Charlotte,

About phones exceeded, yes you can change the masimum-number on the router, that does not require a reboot, the thing is that the router only controls the phone when the CM fails, calle SRST mode. That is, you need more licenses for the CM in any case.

Then for the trunking, you need to trunk also the port that goes to the router, that is I would need to see a diagram with all the switches connections and configs.

One the router you also need to configure DHCP for the voice VLAN as I was suggesting before.

Actions

This Discussion