PC Network Issues Behind IP Phone

Unanswered Question
Mar 29th, 2007
User Badges:

We have a couple of PCs that won't log onto the Windows domain when connected through a 7940 phone. If we logon directly connected and then switch back to the path through the phone, then the network connectivity for the user is just fine. We've tried different phones and ports and just can't seem to figure out what the root cause is. Any ideas?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
kelvin.blair Thu, 03/29/2007 - 06:40
User Badges:
  • Silver, 250 points or more

Are you getting correct ip information on the workstations? Verify that DNS is showing up correctly on these workstations. Remember if you're running AD, it relies on DNS unless you have WINS enabled. Verify your switchports where the phones are configured correctly.

Benjamin Story Thu, 03/29/2007 - 07:33
User Badges:

The problem is that I can't get the user access to that information until they can logon which they can't do through the phone. I had them do an ipconfig /release and then /renew after they're signed in and see what DHCP info was and it was all correct. The port config is:



interface FastEthernet1/0/13

switchport access vlan 2

switchport mode access

switchport voice vlan 3

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

mls qos trust device cisco-phone

mls qos trust cos

no mdix auto

auto qos voip cisco-phone

spanning-tree portfast



kelvin.blair Thu, 03/29/2007 - 08:20
User Badges:
  • Silver, 250 points or more

This shouldn't make a difference, but your missing "switchport priority extend cos 0". Other then hat the switchport config looks good. So if the plug directly it works fine. What model switch are you working with? Try this not sure if it will help, but worth a try.


int faste 1/0/13

switchport trunk encap dot1q

switchport trunk native vlan 2

swtichport voice vlan 3

switchport mode trunk



Benjamin Story Thu, 03/29/2007 - 08:43
User Badges:

What does the "switchport priority extend cos 0" do? We're using 3750 POE switches.

kelvin.blair Thu, 03/29/2007 - 08:45
User Badges:
  • Silver, 250 points or more

Anything on the other end of the phone is considered as a untrusted device and is marked at layer to to cos 0.

kelvin.blair Thu, 03/29/2007 - 08:46
User Badges:
  • Silver, 250 points or more

On the 3750's the configuration should work with now problems. What version of code are you using on the switch?

Benjamin Story Thu, 03/29/2007 - 08:57
User Badges:

(C3725-SPSERVICESK9-M), Version 12.4(2)T


Not very current, but the other hosts and phones have worked for 2 years.

kelvin.blair Thu, 03/29/2007 - 09:04
User Badges:
  • Silver, 250 points or more

3725 is the IOS for a 3725 router...I was talking about your switches. So your telling me that you have some phones working with the same port config as the ones that don't. Would you by chance have the PC disabled under Call Manager. It is a setting located at device-->Phone-->phone in question--> Product Specific Configuration-->PC Port

Needs to be set to enable Also PC Voice Vlan Access needs to be enabled.

Benjamin Story Thu, 03/29/2007 - 09:09
User Badges:

Darn, grabbed the wrong show ver. Sorry about that. The switch is (C3750-I9-M), Version 12.2(25)SE.


We're running CallManager Express and as far as I know there is no way to switch off that port in CME. Plus the port works, just not for the initial login.

kelvin.blair Thu, 03/29/2007 - 09:17
User Badges:
  • Silver, 250 points or more

You're correct on CME. Sorry Missed that. hmm So can you take a known working phone and plug it up exactly how this one is and see if it experience the problem. Make sure to tell me if it was the same model phone or something different.

kelvin.blair Thu, 03/29/2007 - 10:26
User Badges:
  • Silver, 250 points or more

Did these phones work some where else with no problems?

Benjamin Story Thu, 03/29/2007 - 10:31
User Badges:

Yes. The weird thing is that the problem supposedly follows the PC, but also supposedly they're putting a PC on the same phone in the same place that also fails, but works elsewhere. (Isn't working through a third party fun?)

Actions

This Discussion