CallerID problem from PSTN

Unanswered Question
Mar 29th, 2007

Hi,

I have a very strange problem with callerID from my PSTN.

The lines from the PSTN is connected to a vic2-2fxo card. I PSTN has callerID enabled which I can see whenever a caller calls on the telephone box but when the line is placed on the fxo, it does not display on the IP phones.

When I connected another line from a different PSTN, I get callerID displayed on the IP phones.

When I debug, the vic receives request for the callerID and displays a lenght error for the callerID and displays callerID failed.

PSTN does not know what to do as they're sending callerID.

I'll appreciate everyone's input on this with a fair rating.

TIA,

Kayode

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Thu, 03/29/2007 - 13:09

Does a phone with caller display correctly? Perhaps if it does not, telco will check things for real.

Which SW on the router ? Perhaps it's older and there have been fixes.

Ultimately the tac may have seen the issue already and know that to do.

Suggestion: try to get ISDN BRI if possible. You will have a digital connection, and working caller ID and DID no matter the telco you are connected to.

olakayode Thu, 03/29/2007 - 23:35

Thanks for your reply. A phone box with an LCD displays the callerID from the PSTN.

The IOS on the router is ok as the same router displays callerID with another PSTN.

I would not want to request for an ISDN line from telco since this solution is required to work.

Regards,

Kayode

Paolo Bevilacqua Fri, 03/30/2007 - 05:03

Hi, is not said the IOS is OK, because the IOS is software and can have bugs. For example, in treating correctly a caller-id string that a slightly different format. Which IOS are you using now ?

My suggestion about ISDN was because ISDN works always, while analog lines often gives problems, as you can see yourself.

pkentsmith Fri, 04/20/2007 - 02:59

Hi,

Is this gateway (well the FXO card) CCM controlled via MGCP?? I've got something in the back of my mind thats saying MGCP and caller ID has problems - i could be wrong

I'll do some digging in the Cisco GWGK book tonight as i think thats where i saw it

Regards

PKS

noelger Sat, 04/28/2007 - 19:42

That is the question. Caller ID on FXO only works via H.323. It does not work with MGCP.

thx,

Neal

olakayode Sun, 04/29/2007 - 04:04

Thanks to all for your responses.

I finally got it resolved. I still believe its a bug in the IOS.

Solution:

I'm running CME4.0 on 2811 but since the 2811 didn't have DSPs, I had to install FXO on 1760V that had DSP chip. This was how the problem started with CallerID working with some PSTN while it didn't work with other PSTNs.

The problem got resolved after I installed PVDM2 on the 2811 and moved the FXO card to the 2811.

The problem does not have anything to do with MGCP or ISDN.

Regards,

Kayode

adandrade Mon, 04/30/2007 - 14:38

Hi, I have the same issue going on a 2811. So is this the way got it fixed? by simply putting a PVDM2 in the 2811 ?

olakayode Tue, 05/01/2007 - 08:16

Hi,

I won't say this really fixed the problem. For the scenario I was having, this fixed it. We might not be having similar problems but if you can explain the CME deployment with the devices used, I might be able to assist.

What type of VIC are you using?

Is your PSTN sending callerID and if yes, have you confirmed?

Regards,

Kayode

Actions

This Discussion