SRST FXO ports no inbound calling

Unanswered Question
Mar 29th, 2007

I have implemented SRST on a 2811 router. When in SRST mode people can make outbound call but can not recieve calls. I have done an debug voice ccapi inout but I do not see any number coming in from telco just blanks where you would normally see an extention. When the call comes in I hear it ring once and then get dial tome. Any help would be appreciated. Thanks

Jason

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
dgahm Thu, 03/29/2007 - 17:20

Jason,

What kind of ports are the calls coming in on? Digits will only be seen inbound on FXS/DID, CAS T1, or PRI T1.

In SRST mode the calls are handled with H323, so you need a POTS peer defined that either does a connection PLAR (ringdown), links the call to a TCL script for AA, or configures DID so the router will collect digits.

A ring once and dial tone is the symptom if the default peer is being matched.

Can you post your config?

Dave

jason-calbert_2 Thu, 03/29/2007 - 17:58

Dave,

Thanks for the responce. The calls are coming in on FXO ports(these do not appear to be DID FXO ports). Here is my config.

voice call send-alert

voice rtp send-recv

ccm-manager fallback-mgcp

ccm-manager redundant-host X.X.X.X X.X.X.X ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server X.X.X.X

ccm-manager config

!

!

!

!

controller T1 0/0/0

framing sf

linecode ami

channel-group 0 timeslots 1-24 speed 56

!

fair-queue

!

!

no crypto isakmp ccm

!

!

!

!

interface FastEthernet0/0

no ip address

no ip redirects

no ip unreachables

no ip route-cache cef

no ip route-cache

no ip mroute-cache

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address X.X.X.X 255.255.255.0

ip access-group 101 in

ip access-group 101 out

ip helper-address X.X.X.X

no ip redirects

no ip unreachables

ip accounting access-violations

no ip route-cache

no ip mroute-cache

!

interface FastEthernet0/0.171

encapsulation dot1Q 171

ip address X.X.X.X 255.255.255.0

ip helper-address X.X.X.X

ip helper-address X.X.X.X

no ip redirects

no ip unreachables

no ip route-cache

no ip mroute-cache

standby 171 ip X.X.X.X

standby 171 preempt

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:0

bandwidth 1344

ip address X.X.X.X 255.255.255.252

no ip redirects

no ip unreachables

no ip route-cache cef

no ip route-cache

!

router eigrp 4

network 10.0.0.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.201.205.1

!

!

no ip http server

no ip http secure-server

!

!

!

!

tacacs-server host X.X.X.X

tacacs-server host X.X.X.X

tacacs-server directed-request

tacacs-server key xxx

!

control-plane

!

!

!

voice-port 0/1/0

!

voice-port 0/1/1

!

voice-port 0/1/2

!

voice-port 0/1/3

!

voice-port 0/2/0

timing hookflash-out 500

!

voice-port 0/2/1

timing hookflash-out 500

!

voice-port 0/2/2

timing hookflash-out 500

!

voice-port 0/2/3

timing hookflash-out 500

!

mgcp call-agent X.X.X.X 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

mgcp package-capability pre-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface FastEthernet0/0.171

mgcp bind media source-interface FastEthernet0/0.171

!

mgcp profile default

!

!

!

dial-peer voice 999020 pots

port 0/2/0

!

dial-peer voice 999021 pots

application mgcpapp

port 0/2/1

!

dial-peer voice 999023 pots

port 0/2/3

!

dial-peer voice 10 pots

preference 1

application mgcpapp

destination-pattern 9T

incoming called-number .

port 0/2/0

forward-digits all

!

dial-peer voice 20 pots

preference 2

application mgcpapp

destination-pattern 9T

port 0/2/1

forward-digits all

!

dial-peer voice 30 pots

preference 3

destination-pattern 9T

incoming called-number .

port 0/2/2

forward-digits all

!

dial-peer voice 40 pots

preference 4

application mgcpapp

destination-pattern 9T

port 0/2/3

forward-digits all

!

!

!

!

call-manager-fallback

secondary-dialtone 9

max-conferences 8

limit-dn 7940 2

limit-dn 7960 2

ip source-address X.X.X.X port 2000

max-ephones 36

max-dn 72 dual-line

alias 1 49409 to 43161

alias 2 49410 to 43163

alias 3 49411 to 43187

alias 4 49412 to 48182

alias 5 49423 to 45585

time-zone 8

Any help would be apprecaited.

dgahm Thu, 03/29/2007 - 18:15

Jason,

Where does the Call Manager send the incoming calls when operating normally with MGCP?

At most of our sites with FXO ports we run the old SRST 2.1 TCL script which forwards the calls to a call center pilot number if reachable, or invokes an AutoAttendant when the WAN is down. The other solution is to configure the ports to use H323 normally, with connection PLAR to forward the calls to the local receptionist. This works the same regardless of SRST status.

Please rate helpful posts.

Dave

jason-calbert_2 Thu, 03/29/2007 - 18:19

These ports are not even registered in callmanager. We don't need them to be the ports only need to be used with SRST. Just haven't gotten around to taking MGCP off of the router.

what I want to happen is I have the 4 FXO ports that have an extention associated with them. These numbers will be associated with DN's on the IP phones.

So I need both inbound and outbound dialing on these ports. Is this possible. I hope I explained this well enough. Thanks I appreciate the help

dgahm Thu, 03/29/2007 - 20:39

Jason,

Remove all mgcpapp from POTS peers.

Configure connection PLAR for each FXO port. XXXX will be the phone you want to ring. All ports can go to the same phone, or to different phones.

voice-port 0/2/0

connection plar opx XXXX

Add VOIP peer(s) to route all XXXX calls to Call Manager when WAN link is up. You also need a H323 gateway configured in the Call Manager. You may already have this to route outbound calls using a 9.@ route pattern.

dial-peer voice 100 voip

destination-pattern XXXX

session target ipv4:10.X.X.X Call Manager IP address.

In SRST mode the phones will register with the router. Incoming calls will route directly to the XXXX phones. They will dial out with a 9 plus number matching the existing peers.

Please use the pulldown menu to rate helpful posts.

Dave

Actions

This Discussion