Network Printer Problems

Answered Question
Mar 30th, 2007

I am seeing a recurring problem at my site and have no clue how to solve it.

When connecting a networkable printer, it takes long periods of time before the printer will start talking to the network. More specifically, the printer gets connected link and activity lights on and blinking. The switch interface is configured properly. When I do a "show mac-address dynamic" it shows the correct MAC address. Under the protocols section it lists just "other" and until it lists "ip" I am unable to talk to the printer. Sometimes it may take hours before it starts talking. I believe this is switch related, because it happens with both different makes and models of printers. I am clueless at this point, any help would be greatly appreciated.

Correct Answer by dgahm about 9 years 10 months ago

James,

When replacing network printers, and using the same IP address, you often need to log into the router on the subnet (default gateway), and clear arp.

ARP cache entry timeout is 4 hours, and printers often just sit and wait for someone to talk to them, so the router keeps sending to the old mac address.

Please rate hlepful posts.

Dave

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
mahmoodmkl Fri, 03/30/2007 - 10:53

Hi

Can u verify if spanning-tree portfast is configured on the interface.

Thanks

Mahmood

a17j13j05 Fri, 03/30/2007 - 13:24

Catalyst 2900's, 4000's, and 4500's.

HP and Lexmark printers of various models.

situwayne Fri, 03/30/2007 - 13:38

you listed several models of switches and print servers. I assume this problem is consistant across these switches?

1. try enable spantree portfast as suggested.

2. do you see errors on the switch interface? crc, runts, collison, etc?

3. once the print server is connected, can you ping it from its default gateway (router)? can you ping it from another vlan?

jasonrandolph Fri, 03/30/2007 - 14:31

enable spanning-tree portfast on the interface as suggested below.

This will cut the spanning-tree negotiation period down to about 15 seconds versus 45 or so.

Also try hard setting speed/duplex for both the port and printer. There is no duplex negotiation process in 10/100 Ethernet. Older printers can be especially sensitive to this, and I've seen newer NICs that will actually pass no traffic if the duplex is mismatched between the card and switch.

a17j13j05 Mon, 04/02/2007 - 12:25

I have enabled portfast as recommended, checked for errors, and it still is not talking. I have tried pinging it from the gateway with no results. I haved checked my DNS and WINS servers for any entries and they show none. I am at a loss for what to do.

Danilo Dy Tue, 04/03/2007 - 04:52

Hi,

I have similar problem before from a large corporation. What I did is separate the networked printers vlan from the other vlans (i.e. users, servers, wireless, etc..), that means dedicate one network for networked printers. For some reason, broadcast storm from other vlans affect networked printers. In my case however, is virus storm from user vlan affects the networked printers.

Try enabling vtp pruning for a while, it may help. Also, upgrade your networked printers NIC firmware.

Correct Answer
dgahm Mon, 04/02/2007 - 12:44

James,

When replacing network printers, and using the same IP address, you often need to log into the router on the subnet (default gateway), and clear arp.

ARP cache entry timeout is 4 hours, and printers often just sit and wait for someone to talk to them, so the router keeps sending to the old mac address.

Please rate hlepful posts.

Dave

b.petronio Tue, 04/03/2007 - 05:12

Hi James,

If the interface Speed and Duplex is in Auto Mode, what it will learn?

100Full, 100Half, 10Full, 10Half ?

If it doesn't learn 100Full, force it to what it learned.

The interface is getting any kind of Errors?

Past the "show interface Interface Number", to us.

Teorically, the spanning-tree portfast, will not result cause u said, "Sometimes it may take hours before it starts talking".

Best Regards,

Petr?nio

Actions

This Discussion