VoIP good priority

Unanswered Question
Mar 30th, 2007
User Badges:

Hello,


I'm looking for good solution to priority VoIP packages in routers.

We have about 10 Cisco routers, and sometimes when someone downloading files

from internet connection over VoIP telephone is slow/disconnent. Is this

solution is good to priority packages:


access-list 100 permit ip any 'IP_VOIP_SERVER'

access-list 100 permit ip 'IP_VOIP_SERVER' any


class-map test_speed

match access-group 100


policy-map test

class test_speed

set ip precedence 5

class class-default

set ip precedence 0


interface Ethernet0/0

service-policy input test



Maybe there is a better solution ? Those packages are only marked with

higher prioryty, is this part of config I should write on all my routers'???


Thanks

Pawel R.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Brandon Buffin Mon, 04/02/2007 - 09:06
User Badges:
  • Purple, 4500 points or more

Take a look at the QoS SRND below.


http://www.cisco.com/application/pdf/en/us/guest/netsol/ns432/c649/ccmigration_09186a008049b062.pdf


Specifically, look at the WAN Aggregator QoS Design section. Under this section, you will find Classification/Provisioning Models as well as sample configurations for different types of links and link speeds.


Hope this helps. If so, please rate the post.


Brandon

PawelRutkowski Tue, 04/03/2007 - 11:17
User Badges:

I read what You post, and I think my solution for packed priority is good - i post it in my first post. But when I applied it in my all routers it's dosen't help, still some VoIP Gateway have lags about 2000ms. Those lags is beetwen gateway in my network and sip server which is in my network too. So when i apllied this to my router it should helpd but dosen't not.

Hieu Cao Tue, 04/03/2007 - 16:10
User Badges:

Your packets are marked with ipp 5, but you're not really putting it in the priority queue. Class class-default has already been set at dscp 0, so there's no need to specifiy it there.


You can try something like this:


class-map match all VoIP

match ip dscp ef

class-map match-any Call-Signaling

match ip dscp cs3


policy-map test_speed

class VoIP

priority 512 **VoIP packets are placed in the priority queue( or you can use " priority percent" of T1 bandwidth if you like)

class Call-Signaling

bandwith percent 5

class class-default

fair-queue

random-detect dscp-based


Then apply the test_speed policy to the serial int, outbound (service-policy output test_speed)


Take a look at the document link from the Brandon. It contains very good explanation and examples that you can follow to create the optimum QoS for your enviroment.


HTH,

hieu

Actions

This Discussion