SSH version warning!

Unanswered Question
Mar 31st, 2007

Now that I have Cat4006 Switch - SSH version 8.4.11.GLX-K9, when I connect with the SSH clent, it keeps giving me a warning that the switch is using SSH1 which has many issues with it. How do I ensure I am using the right SSH and how can I get the Switch to be SSH verion 2.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
londint Sat, 03/31/2007 - 09:31

Its a Cat 4006. It is running Cat Cat4000-K9-8-4.11 GLX.

Its an old switch


ahmet-saat Sat, 03/31/2007 - 10:52

here what you can do,

to set ssh server version

router(config)# ip ssh version [1|2]

to see what version you use

router# show ip ssh

Please Rate if it helps

glen.grant Sat, 03/31/2007 - 12:43

Ahmet it is catos , it would have to be a "set" command . It would be "set ssh mode v2".

londint Mon, 04/02/2007 - 04:02

Yes, it is CatOS but this command is not on the Switch. It is a Cat 4006.


Amit Singh Mon, 04/02/2007 - 04:27


SSH Version 2 is not supported on CatOS sup engine on Cat4500.As CatOS on Cat4500 is already EOL/EOS so there will be no future support for the same.

SSHV2 is only suported on IOS based sup engine. Please see the release notes for the same:

HTH,Please rate if it does.

-amit singh

londint Tue, 04/03/2007 - 06:30

Thanks Guys

Does that mean I will just have to use the SSH v 1 version on the Cat4003/4006. How can I get this to be more secure then? Becos the SSHv1 is kind of worrying.

Amit Singh Tue, 04/03/2007 - 09:25

Yes, you have to just use SHHv1 with Cat4003/4006 using Sup1/2. As these sup only supports CatsOS. As cat4000 is EOL/EOS, I would suggest you to upgrade the Cat4000 to Cat4500 and get the IOS sup engine which will support more enhanced featureset.

HTH,please rate if it does.

-amit singh


This Discussion