Kypamop Mon, 04/02/2007 - 07:43

Hi,

Dunno actually if the feature exists in IOS now. If you have a link about this please post it here.

Maybe you should try to play with different Loopback addresses. For instance create two Loopbacks on the tail-end, then setup two TE-tunnels from head-end. Be sure to advertise VRFs with different next-hop (pointing to Lo1 and Lo2 accordingly) via MP-BGP. But i'm not sure that there's no "hidden obstacles" with this scenario.

Harold Ritter Mon, 04/02/2007 - 15:14

Mel,

One way to do it is

- Setup a tunnel (no autoroute announce) on the ingress PE

- configure a static route through that tunnel interface as follow:

ip route x.x.x.x 255.255.255.255 tu0

- And use this same address as the bgp next-hop on the egress PE using the following command:

ip vrf xxx

bgp next-hop loxx

This way only the traffic destined to this address will traverse this specific tunnel.

Hope this helps,

mel_bs Mon, 04/02/2007 - 19:36

Hi,

I have plotted below a similar configuration to my customer setup for the per-vrf TE which you suggest.

PE2 is a central vrf and has extranet to customer 1 and 3 vrf?s. Since there will be a defined bgp nex-hop on the cust_1 vrf pointing to PE2, and while central vrf will also have bgp next-hop pointing to PE1, what will happen to the PE2 central vrf going to PE3 cust_3 vrf traffic?

==============================================

PE1 :

ip vrf cust_1

rd 1:1

route-target export 1:1

route-target import 1:1

bgp next-hop Loopback1

!

interface Loopback1

description NEXT_HOP VRF cust_1

ip address 192.168.1.211 255.255.255.255

!

ip route 192.168.1.221 255.255.255.255 Tunnel1

PE2 :

ip vrf central

rd 1:2

route-target export 1:2

route-target import 1:2

route-target export 1:1

route-target import 1:1

route-target export 1:3

route-target import 1:3

bgp next-hop Loopback1

!

interface Loopback1

description NEXT_HOP VRF cust_1

ip address 192.168.1.221 255.255.255.255

!

ip route 192.168.1.211 255.255.255.255 Tunnel1

!

!

PE3 :

ip vrf cust_3

rd 1:3

route-target export 1:3

route-target import 1:3

!

==============================================

Thanks,

Mel

Harold Ritter Tue, 04/03/2007 - 05:05

Traffic from PE2 to PE3 and vice versa will continue to be routed through the LDP signaled LSP and therefore following the IGP route.

Hope this helps,

Actions

This Discussion