NNM 7.5.1 and Ciscoworks 2.6 Integration

Answered Question
Apr 1st, 2007
User Badges:

Everything went well except for one thing, when I try and launch ciscoview for a given node from the map, iexplore opens with a 403 forbidden message for the following URL:

http://ciscoworks-pr01:1741/CSCOnm/servlet/com.cisco.nm.cvw.servlet.CvServlet?device=dotplac41


When I go into my ciscoworks server separately, and launch ciscoview separately this is the url for viewing the device:

https://ciscoworks-pr01/CVng/chassis.do?deviceip=dotplac41



Now, if i take that url and put it into IE from my NNM server directly, it acts as it should...seems to me that the NNM GUI customization created by the latest integration package does not work with LMS 2.6...it tries to launch the following:

Action "CWCiscoView" {

SelectionRule isNode && isCisco;

Command "C:\\PROGRA~1\\INTERN~1\\iexplore.exe http://ciscoworks-pr01:1741/JSP/cmf/security/AutoLogin.jsp?URL=http://ciscoworks-pr01:1741/CSCOnm/servlet/com.cisco.nm.cvw.servlet.CvServlet?device=$OVwSelection1";

}

The url in there is attempting to run a jsp script called autologin(which apparently does not work)...is this a feature that is broken on my LMS installation, or am I right in saying the integration package is out of date?


I am thinking about just changing the GUI customization so that it goes to the URL i found manually. Any other ideas?




Correct Answer by Joe Clarke about 10 years 3 months ago

The problem is not the URI, but the protocol. Your server is configured for HTTPS, not HTTP. When you ran nmic, you must have chose http for your protocol. Run nmic again to change the integration options, and specify https instead, or just modify the files directly in NNM (i.e. change http:// to https:// and remove the :1741 port from the URLs).

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Joe Clarke Sun, 04/01/2007 - 09:39
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

The problem is not the URI, but the protocol. Your server is configured for HTTPS, not HTTP. When you ran nmic, you must have chose http for your protocol. Run nmic again to change the integration options, and specify https instead, or just modify the files directly in NNM (i.e. change http:// to https:// and remove the :1741 port from the URLs).

Perdue Farms Sun, 04/01/2007 - 09:43
User Badges:

well that was stupid of me...1741 is normally used...oh well thanks! that did it

Actions

This Discussion