how to hide prefix digits from routelist

Unanswered Question
Apr 2nd, 2007

I use CM4.2(1) and as5400xm with h.323 procotol and i have multitennant company that use multiple E1 on as5400xm so i use routelist prefix to add to number when send to router. and router match dial-peer destination pattern with prefix number.

the problem is when use this scenario. ipphone will display prefix and user was paranoid.such as i try to call 9029115218

then ipphone will display 919029115218.the 919 is prefix from routelist.

so please tell me if anyone have solution for this

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
s-pinto Wed, 04/04/2007 - 15:09

Hi,

Can you send the number without the 919 to the router? If you can then, is the dial-peer a "pots" dial-peer?

If it is, then you can to the following:

Do not prefix digits at ccm. Pass the entire number to the gateway.

On the dial-peer match the destination-pattern with the 9029115218 and add the "prefix 919" command.

You can use num-exp or translation-rules as an alternative on the gateway.

Hope this helps. If you need further assistance please let me know.

Regards,

S?rgio Pinto

gogasca Wed, 04/04/2007 - 15:26

This is what I normally use for INT calls when access code is 9

voice translation-rule 1

rule 1 /^9\(.*\)$/ /\1/

!

!

voice translation-profile INT

translate called 1

!

!

dial-peer voice 300 pots

description TO PSTN INTERNATIONAL

translation-profile outgoing INT

destination-pattern 9011T

port 1/0:0

!

I have a similar case in the past and tried:

voice service voip

no supplementary-service h225-notify cid-update

!

Above commend will stop GW from sending h225 notify message

Joseph Martini Fri, 10/01/2010 - 11:09

On newer 6.x and later there's a call manager service parameter "Always Display Original Dialed Number" that is helpful in cases like this too when calling though a translation.

Actions

This Discussion