Unity 4.2 with PIMG need to insert delay before answer

Unanswered Question
Apr 3rd, 2007

I'm using an separate autoattendant which has a small delay before completing a transfer. This is a problem when phones are busy or fwd all to Unity. Callers don't hear the first couple of seconds of a greeting.

There is an advanced setting for delay before prompt but it interferes whith the "blank greeting" setting -actually putting the delay before all greetings including blank.

I just need Unity to answer after 2-3 seconds - not immediately.

Any solutions?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Tommer Catlin Tue, 04/03/2007 - 10:21

What version software is loaded on the PIMG? Log into the PIMG and see what version is loaded

Tommer Catlin Tue, 04/03/2007 - 10:41

Depending on what you have the PIMG integrated to, there are some newer versions for the PIMG that will probably help you.

Login to Cisco and go to the voice software download, Unity, PIMG

There is 5.1 out that may help.

sposte Tue, 04/03/2007 - 10:53

The PIMG's are on Nortel M1.

I will see if there is a configuration setting for "delay before answer" on the PBX integration side.

Tommer Catlin Tue, 04/03/2007 - 10:57

Does it happen with everyone, or just a couple people?

There have been issues with the PIMG trying to pharse the incoming display name from the PBX. It delays giving the call to Unity, or errors out.

eschulz Tue, 04/03/2007 - 11:04

I think the specific bug fix in the 5.1 firmware that might help is...

IPY00034869 All (SIP)

Start of played prompts to PSTN is truncated when receiving SIP call from gateway.

Resolution: Gateway sends ACK after the inbound TDM call has been answered.

sposte Tue, 04/03/2007 - 11:23

This is NOT a bug

As I explained before a separate server (OCTEL) is doing the Autoattendant.

The cutoff is caused by the AA ports having to delay a bit before completing the transfer.

I need the PIMG to pickup after 2 seconds, not immediately.


eschulz Tue, 04/03/2007 - 11:58

Sorry, I don't know of a way to add such a delay. The only thing I could suggest would be to have folks record a bit of silence at the front of their greetings.

However, there is a bug in earlier PIMG code that causes clipping on the first prompt when answering a call. This bug on top of the AA's delayed transfers could cause even more clipping. By eliminating the bug, you may at least reduce some of the clipping.

Another direction to pursue would be to have the AA release the transfers quicker. Sounds like maybe it is doing a wait-answer type supervised transfer where it needs to hear Unity answered the call before releasing the transfer. Blind transfers might work better here.

sposte Tue, 05/22/2007 - 05:29

Here is the fix: You have to edit the config.ini of the PIMG unit to force a delay before answering. Also the PIMG config.ini is default to supervised transfer which has to be changed to blind transfer (the setting in Unity SA has no effect).



This Discussion