Weird Option 2 difference on Unity failover system

Answered Question
Apr 3rd, 2007
User Badges:
  • Bronze, 100 points or more

On our Primary Unity server, when you hit 2, it says "Enter the extension". However, on our Failover Unity server, when you hit 2 it says "Spell the name or distribution list".


Is this normal, or did the configs get out of sync somewhere? Both are running 4.0(5) with TSP 8.1(3).

Correct Answer by eschulz about 9 years 12 months ago

Unfortunately, not everything in the SA is in the DB. Some of it is still written out to the registry where it does not get replicated. The Dialing Domain settings are a good example of this. From the Advanced Settings Tool, it looks like the setting you are interested in uses this registry key:

\Software\Active Voice\Conversations\1.0\Subscriber Send


-Eric

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
ranpierce Tue, 04/03/2007 - 13:38
User Badges:
  • Silver, 250 points or more

The first place I would look is in the SA Configuration\settings page:


Address messages to other subscribers:

Enable spelled name search


Make sure the setting is the same on both servers. Hope this it.


rlp

johnnylingo Tue, 04/03/2007 - 13:43
User Badges:
  • Bronze, 100 points or more

Indeed, the settings are different. I'm just confused as to why, because I thought the failover pulled all settings from the primary via SQL replication. Hmmm.

ranpierce Tue, 04/03/2007 - 13:55
User Badges:
  • Silver, 250 points or more

Me too, hmm. Everything in the SA should be in a SQL table. I took a quick look but was not able to find that setting in a table.


I also found SQL replication errors in my unitydb on my failover server. :-(


rlp

johnnylingo Tue, 04/03/2007 - 14:03
User Badges:
  • Bronze, 100 points or more

Are you seeing the following in the Primary's event viewer every 30 minutes by chance?


AvCsNodeMgr unable to connect to SQL Server on LocalHost. Error 0x80040000.


ranpierce Tue, 04/03/2007 - 14:08
User Badges:
  • Silver, 250 points or more

No, I think the conflict in the Unitydb might have happened at install of the failover server when we ran failoverconfig. It only happened once and everything is working now.


That is an interesting username you have.

Correct Answer
eschulz Tue, 04/03/2007 - 14:37
User Badges:
  • Cisco Employee,

Unfortunately, not everything in the SA is in the DB. Some of it is still written out to the registry where it does not get replicated. The Dialing Domain settings are a good example of this. From the Advanced Settings Tool, it looks like the setting you are interested in uses this registry key:

\Software\Active Voice\Conversations\1.0\Subscriber Send


-Eric

eschulz Tue, 04/03/2007 - 14:43
User Badges:
  • Cisco Employee,

Ok, that's not the setting you are looking for but the point still stands that not everything entered in the SA gets replicated with the database.

manjunathgc Thu, 02/09/2012 - 11:14
User Badges:

I have come acros similar error ... in my case i do not see 'Subscriber Send' under regirtry config path

key:

\Software\Active Voice\Conversations\1.0\ ....  can you please guide me on what has to be done

Actions

This Discussion