ATA 186 inside IP cloud ok from PSTN no fax

Unanswered Question
Apr 3rd, 2007

Hi, I have a problem with a ATA 186. Device is configured the same like others in Network wich works. But this device is able to send and receive faxes within the IP Network, but I get no fax from a fax wich is in the outside telephony cloud. Any idea? Help is appreciated.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
ezy Wed, 04/04/2007 - 21:34

Hi, attached you?ll find the config of the voice gw and the ATA186,

I also attached some screen shots and logs I collected with prserv.

ezy Thu, 04/05/2007 - 01:17

Hi all, found the problem. It was an entry in the voip peer to the call manager. The negotiation with the fax was overwriten by the gateway. So, the solution was:

dial-peer voice 100 voip

modem passthrough nse codec g711alaw | the necessary codec

fax rate disable

This causes the GW to comunicate with the codec the fax expects.

pacameron Sat, 04/07/2007 - 04:28

The most common reason for faxes to fail in this setup is due to clock slips on the digital interface caused by a clocking mismatch.

You need to add the following config -

network-clock-select 1 BRI0/0/0

network-clock-select 2 BRI0/0/1

network-clock-select 3 BRI0/1/0

network-clock-select 4 BRI0/1/1

Without these commands, the PVDM2 DSP module is being driven by the router's internal oscillator, while the PCM data on the BRI ports is using the clock provided by the service provider. The above commands will synchronise the DSP with the external clock reference (also adds a failover heirachy) and should remove the clock slips which are causing the faxes to fail.


This Discussion