Database Space Reclaimer problem in LMS 251

Unanswered Question
Apr 4th, 2007

I am running LMS 2.5.1 on Solaris 9 and trying to reclaim database space in the three syslog DB files (SyslogFirst.db, SyslogSecond.db, SyslogThird.db) in RME as they have grown excessively. I reduced the number of days to keep to 7. After running: pdterm RMEDbEngine and pdexec RMEDbEngine, I used a class file received from Cisco to reclaim space with the following syntax:

[root] 271: "/opt/CSCOpx/lib/jre/bin/java -cp /tmp/DBSpaceReclaimer.class:/opt/CSCOpx/lib/classpath:/opt/CSCOpx/www/classpath:/opt/CSCOpx/MDC/tomcat/webapps/rme/WEB-INF/classes:/opt/CSCOpx/MDC/tomcat/webapps/rme/WEB-INF/lib/log4j.jar DBSpaceReclaimer"

On execution I receive the following error: "Exception in thread "main" java.lang.NoClassDefFoundError: DBSpaceReclaimer"

Can you let me know what I'm doing wrong? Is the syntax correct? The permissions on the .class file was set to 644.

Thanks for any help you can provide.

Always, Ken.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Joe Clarke Wed, 04/04/2007 - 10:32

-cp stands for CLASSPATH. It should only be a colon separated list of directories. So:

/opt/CSCOpx/lib/jre/bin/java -cp /tmp:/opt/CSCOpx/lib/classpath:/opt/CSCOpx/www/classpath:/opt/CSCOpx/MDC/tomcat/webapps/rme/WEB-INF/classes:/opt/CSCOpx/MDC/tomcat/webapps/rme/WEB-INF/lib/log4j.jar DBSpaceReclaimer

kviola1 Wed, 04/04/2007 - 19:08

Thanks Joe. That worked. Any thoughts on rmeng.db? That needs to shrink too. Can I use a similar routine for that?

Thanks again, Ken.

RMEDbEngine needs to be restarted before this tool is run.

dropped DB space - SyslogSecond.db

Successfully re-created db space SyslogSecond.db

dropped DB space - SyslogThird.db

Successfully re-created db space SyslogThird.db

SyslogFirst.db cannot be deleted.

As one or more application will be down , it is recommended to restart the daemon manager now.

-rw-rw---- 1 root casusers 0 Apr 4 17:35 DBSpaceClaimer.log

-rw------- 1 casuser casusers 19197952 Apr 4 22:58 SyslogFirst.db

-rw-r----- 1 casuser casusers 4096 Apr 4 22:59 SyslogSecond.db

-rw-r----- 1 casuser casusers 4096 Apr 4 22:59 SyslogThird.db

drwxrwxr-x 2 casuser casusers 512 Apr 29 2006 orig

-rw------- 1 casuser casusers 8687013888 Apr 4 22:59 rmeng.db

-rw-r----- 1 casuser casusers 4096 Apr 4 22:59 rmeng.log

drwxr-x--- 2 casuser casusers 512 Apr 26 2006 scripts

Joe Clarke Wed, 04/04/2007 - 19:23

No, shrinking the size of rmeng.db is a much more complex process, and could be a futile task. You need to figure out why the database has grown so large in the first place. If the database contains actual data as opposed to fragmentation, then reloading it will have no effect. The most common cause of database bloat is excessive retention of Change Audit and config records. You should make sure both Change Audit and config purging are configured, and you may want to go through RME > Admin > Inventory > Inventory Change Filter to make sure you are only generating Change Audit records for interesting changes. Additionally, if you have a lot of IOS switches using vlan.dat, you may want to consider enabling the config change filter under RME > Admin > Change Audit > Config Change Filter.

Once you have everything tuned, then you can open a TAC service request to get the instructions for unloading and reloading the RME database. However, it would be safer for TAC to perform these steps over a Meeting Place session.

boldizsar.nagy Mon, 06/04/2007 - 01:12

Hi All,

Tried to shrink the size of syslog[first|second|third].db (explorer.jpg) files after receiving 3,5 million!! syslog a day (syslog.jpg). Forced Syslog Purge was successfull, and switched off FWSM logging.

Now Severity Level Summary report displays approx. 10000 syslogs per day, which is acceptable. But memory usage (task_man.jpg) is still the same, as with 3,5 million syslogs, and .db files size has not changed either. How could i shrind the .db files, to free up some memory?

System: Win2k3 SP1, 2 GB RAM, LMS 2.6

Thanks in advance for Your answer


Joe Clarke Mon, 06/04/2007 - 07:46

The size of database or data space files will not shrink. To recover this disk space, you will need to call the TAC and request DBSpaceReclaimer.class. This will drop the syslog data spaces, and recreate them. This will free up the disk space, but you will lose all syslog messages currently in RME.

Whether or not this will lower the rmeng engine's memory footprint is questionable, since some of this cache memory may be caused by other data in the rmeng database.

pvanvuuren Wed, 06/06/2007 - 02:41

Hi Ken

can you please send me the DBSpaceReclaimer file, I would like to test it and use in our lab. Please.



Joe Clarke Wed, 06/06/2007 - 04:10

You should contact the TAC, and request this class. It should not be posted here.


This Discussion